HDU 1711 Number Sequence 【KMP】

题目链接



Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1


思路:简单KMP模版


WA: xt数组要初始化xt[1] = 1


AC代码:

#include <iostream>
#include <stdio.h>
#include <cstring>
#define N 1000010
#define M 10010

using namespace std;

int a[N],b[M],n,m,xt[M];

void getnext()
{
    int j = 1;
    xt[1]=1;//WA的地方!没有加这个初始化错了三次
    for(int i = 2; i <= m; i++)
    {
        while(b[i] != b[j] && j > 1)
            j = xt[j-1];
        if(b[i] == b[j])
            j++;
        xt[i] = j;
    }
}

int KMP()
{
    if(n < m)
        return -1;
    int j = 1;
    for(int i = 1; i <= n; i++)
    {
        while(a[i] != b[j] && j > 1)
            j = xt[j-1];
        if(a[i] == b[j])
            j++;
        if(j == m+1)
            return i-m+1;
    }
    return -1;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d",&n, &m);
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        for(int i = 1; i <= m; i++)
            scanf("%d", &b[i]);
        getnext();
        printf("%d\n", KMP());
    }
}




 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值