The Suspects

     
C - The Suspects
Time Limit:1000MS     Memory Limit:20000KB     64bit IO Format:%I64d & %I64u

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.  
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).  
Once a member in a group is a suspect, all members in the group are suspects.  
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.  
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
这个题的题意就是:编号为0的人是嫌疑犯,只要是跟编号为0的人有关联的也是嫌疑犯,那么本题就是利用并查集把所有人的关系都建成树,最后再判断编号为1~n-1的人的根节点与编号为0的人的根节点是不是一个,要是一个就说明他俩有关系,则那个人也是嫌疑犯。
#include <stdio.h>
int stack[300000];
int find(int x)
{
    int r,k,j;
    r=x;
    while(r!=stack[r])
        r=stack[r];
    k=x;
    while(k!=r)
    {
        j=stack[k];
        stack[k]=r;
        k=j;
    }
    return r;
}
void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
        stack[fx]=fy;
}
int main()
{
    int n,m,k,i,a,b,j,fx,fy;
    while(scanf("%d %d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        for(i=0; i<n; i++)
            stack[i]=i;
        for(i=0; i<m; i++)
        {
            scanf("%d",&k);
            scanf("%d",&a);
            for(j=0; j<k-1; j++)
            {
                scanf("%d",&b);
                merge(a,b);
            }
        }
        int c=1;
        fx=find(0);                    //先找到编号为0的人的根节点
        for(i=1; i<n; i++)
        {
            fy=find(i);             //不能直接用stack[0]与stack[i]的关系判断它俩的根节点是否为一个,因为有的依然是父节点
            if(fx==fy)                
                c++;
        }
        printf("%d\n",c);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值