题目描述
有n个城市,其中有些城市之间可以修建公路,修建不同的公路费用是不同的。现在我们想知道,最少花多少钱修公路可以将所有的城市连在一起,使在任意一城市出发,可以到达其他任意的城市。
输入
输入包含多组数据,格式如下。
第一行包括两个整数n m,代表城市个数和可以修建的公路个数。(n <= 100, m <=1000)
剩下m行每行3个正整数a b c,代表城市a 和城市b之间可以修建一条公路,代价为c。
输出
每组输出占一行,仅输出最小花费。
示例输入
3 2
1 2 1
1 3 1
1 0
示例输出
2
0
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
int a,b,c;
} st[10010];
int sum[1100];
bool cmp(node p,node q)
{
return p.c<q.c;
}
int find(int x)
{
int r;
r=x;
while(r!=sum[r])
r=sum[r];
return r;
}
int main()
{
int n,m;
while(~scanf("%d %d",&n,&m))
{
for(int i=1; i<=n; i++)
sum[i]=i;
for(int i=0; i<m; i++)
scanf("%d %d %d",&st[i].a,&st[i].b,&st[i].c);
sort(st,st+m,cmp); //对修每条路的成本进行从小到大的排序
int cnt=0;
for(int i=0; i<m; i++)
{
int fx=find(st[i].a);
int fy=find(st[i].b);
if(fx!=fy) //如果该两点不在一条路上,则应该修一条花费最短的路
{
sum[fx]=fy;
cnt+=st[i].c;
}
}
printf("%d\n",cnt);
}
return 0;
}
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
int a,b,c;
} st[10010];
int sum[1100];
bool cmp(node p,node q)
{
return p.c<q.c;
}
int find(int x)
{
int r;
r=x;
while(r!=sum[r])
r=sum[r];
return r;
}
int main()
{
int n,m;
while(~scanf("%d %d",&n,&m))
{
for(int i=1; i<=n; i++)
sum[i]=i;
for(int i=0; i<m; i++)
scanf("%d %d %d",&st[i].a,&st[i].b,&st[i].c);
sort(st,st+m,cmp); //对修每条路的成本进行从小到大的排序
int cnt=0;
for(int i=0; i<m; i++)
{
int fx=find(st[i].a);
int fy=find(st[i].b);
if(fx!=fy) //如果该两点不在一条路上,则应该修一条花费最短的路
{
sum[fx]=fy;
cnt+=st[i].c;
}
}
printf("%d\n",cnt);
}
return 0;
}