The 3n + 1 problem(POJ--1207

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
Consider the following algorithm:
 
		1. 		 input n

		2. 		 print n

		3. 		 if n = 1 then STOP

		4. 		 		 if n is odd then   n <-- 3n+1

		5. 		 		 else   n <-- n/2

		6. 		 GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
题意:对于一个数n,它有自己的cycle length(即根据题目中的程序的出来的数的个数,包括1和其本身;1的cycle length是1),给你一个a与b区间,求此区间内cycle length最长的数.
思路:1.可以先把1到10000的cycle length打表(但有的OJ有代码长度限制),然后再对每组区间进行遍历求结果
        2.直接在主函数中预处理,然后在区间内找结果

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

<span style="font-size:18px;">//仅是打表
#include <cstdio>
using namespace std;
int length[10005];
int main()
{
    freopen("ss","w+",stdout);                             //重定向输出freopen("文件名","打开方式",stdout)
    length[1]=1;
    for(int i=2; i<10005; i++)
    {
        int k=i;
        int sum=1;
        while(1)
        {
            if(k==1)
                break;
            if(k%2==0)
                k=k/2;
            else
                k=k*3+1;
            sum++;
        }
        length[i]=sum;
    }
    for(int i=1;i<10005;i++)
    printf("%d,\n",length[i]);
}
</span>
<span style="font-size:18px;">//预处理
#include <cstdio>
#include <algorithm>
using namespace std;
int length[10005];
int main()
{
    length[1]=1;
    int k;
    for(int i=2; i<10005; i++)
    {
        k=i;
        int sum=1;
        while(1)
        {
            if(k==1)
            break;
            if(k%2==0)
                k=k/2;
            else
                k=k*3+1;
            sum++;
        }
        length[i]=sum;
    }
    int a,b;
    while(~scanf("%d %d",&a,&b))
    {
        int ans=0,t,flag=1;
        if(a>b)                                                                    //这是一个大坑啊,一定要记得判断a,b的大小
        {
          t=a;a=b;b=t;
          flag=0;
        }
        for(int i=a; i<=b; i++)
            ans=max(ans,length[i]);
            if(flag)
        printf("%d %d %d\n",a,b,ans);
        else
        printf("%d %d %d\n",b,a,ans);
    }
    return 0;
}</span>




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值