CRB and His Birthday(HDUOJ--5410

Problem Description
Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with  M  Won(currency unit).
At the shop, there are  N  kinds of presents.
It costs  Wi  Won to buy one present of  i -th kind. (So it costs  k  ×  Wi  Won to buy  k  of them.)
But as the counter of the shop is her friend, the counter will give  Ai × x + Bi  candies if she buys  x ( x >0) presents of  i -th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤  T  ≤ 20
1 ≤  M  ≤ 2000
1 ≤  N  ≤ 1000
0 ≤  Ai, Bi  ≤ 2000
1 ≤  Wi  ≤ 2000

 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:
The first line contains two integers  M  and  N .
Then  N  lines follow,  i -th line contains three space separated integers  Wi Ai  and  Bi .

 

Output
For each test case, output the maximum candies she can gain.
 

   题意:今天是CRB的生日,他的妈妈去商店给他买礼物,由于收银员是他妈妈的好朋友,所以收银员会按照不同礼     物的件数x赠与CRB的妈妈(a*x+b)块糖果。CRB的妈妈总共带了w元钱,总共有n种礼物。t组输入,每组先输入w   和n,接下来n行每行是该种礼物需要花费的价格和对应的a与b。求CRB的妈妈最多能获得多少糖果。

  思路:由于获得糖果的块数与礼物的件数不是简单的线性关系即还要加一个常数,则要将该问题当成01背包和完全     背包一起处理。如果要求得的关系是单纯的线性关系即y=a*x这种,则可直接当作完全背包来考虑;如果要求得的关   系包含一定的常数即y=a*x+b这种,则要将该种物品分为两种物品来解决,一种是特殊物品价值为a+b,因为其只有     一件所以此种当作01背包来处理;另一种是普通物品价值为a,因为其有无数件所以此种当作完全背包来处理。详解   看一下代码。

Sample Input
  
  
1 100 2 10 2 1 20 1 1
 

Sample Output
  
  
21
 

   Hint

     CRB's mom buys 10 presents of first kind,and receives 2*10+1=21 candies.

 
<span style="font-size:18px;">#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define INF 0x3f3f3f3f
#define esp 1e-9
using namespace std;
int dp[2500],price,a,b;
int main()
{
    //freopen("lalala.text","r",stdin);
    int t,w,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&w,&n);
        memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
        {
            scanf("%d %d %d",&price,&a,&b);
            for(int j=w; j>=price; j--)         //对于当前物品看作特殊物品的情况,01背包
                dp[j]=max(dp[j],dp[j-price]+a+b);
            for(int j=price; j<=w; j++)       //对于当前物品看作普通物品的情况,完全背包
                dp[j]=max(dp[j],dp[j-price]+a);
        }
        printf("%d\n",dp[w]);
    }
    return 0;
}
</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值