Currency Exchange【POJ--1860】【SPFA】

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.
题意:第一行输入n,m,s,v,有n种货币,有m种货币兑换方式,Nick有s货币v个,问Nick经过这几种货币兑换方式是否能够升值,若能就输出YES,否则输出NO。
思路:判断这几种兑换方式构成的图能否构成正环即可,即Nick通过一圈兑换后他手中的货币还是s型并且价值升高了。

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

#include <cstdio>
#include <queue>
#include <cstring>
#define esp 1e-9                    //定义esp为0.000000001用以判断double型的数与0的比较
using namespace std;
int n,s;
double price;
typedef struct Edge          //typedef:定义该结构体名为Edge
{
    int v;
    double r,c;
} Edge;
Edge eg;
int dcmp(double x)           //比较double型的数与0的大小
{
    return x<-esp?-1:x>esp;  //如果x<-esp就说明x<0;如果x>esp就说明x>0;否则就=0
}
vector<Edge>vct[150];     //一个存Edge结构体的数组
double dis[150];               //记录从源币兑换成该币的价值;
int in[150];                        //记录变成该种币型的次数
bool vis[150];                    //标记该种币型是否在队列中
bool SPFA()                         
{
    int x,y;
    double z,w;
    queue<int>q;
    memset(dis,0,sizeof(dis));
    memset(vis,0,sizeof(vis));
    memset(in,0,sizeof(in));
    dis[s]=price;               
    q.push(s);
    while(!q.empty())
    {
        x=q.front();
        q.pop();
        vis[x]=0;                //0表示该种币型已出队
        for(int i=0; i<vct[x].size(); i++)        //只要与该种币型能兑换的都遍历一遍
        {
            y=vct[x][i].v;
            z=vct[x][i].r;
            w=vct[x][i].c;
            if(dcmp(dis[y]-(dis[x]-w)*z)<0)          //只要升值了就更新当前币型的价值
            {
                dis[y]=(dis[x]-w)*z;
                if(!vis[y])                                    //只要当前币型没有在队列中就入队
                {
                    in[y]++;
                    if(in[y]>=n)                         //只要该币型入队的次数>=n就说明存在正环
                        return true;
                    q.push(y);
                    vis[y]=1;
                }
            }
        }

    }
    return false;
}
int main()
{
    freopen("aa.text","r",stdin);
    int m,u,v;
    while(~scanf("%d %d %d %lf",&n,&m,&s,&price))
    {
        for(int i=0; i<m; i++)
        {
            scanf("%d %d %lf %lf",&u,&v,&eg.r,&eg.c);
            eg.v=v;
            vct[u].push_back(eg);
            scanf("%lf %lf",&eg.r,&eg.c);
            eg.v=u;
            vct[v].push_back(eg);
        }
        if(SPFA())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}<strong>
</strong>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值