Arbitrage【POJ--2240】【SPFA】

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
题意:多组输入,每组输入一个n(n=0时结束程序)表示有n种货币,接下来n行是n种货币的名称,然后输入m,表示有m种兑换方式,最后m行输入x,w,y表示一个x可以换w倍的y。如果最后货币能升值则输出Yes;否则输出No。
思路:就是判断有无正环。

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#define INF 0x3f3f3f3f
using namespace std;
int n;
map <string,int> mp;
typedef struct Edge
{
    int from,to;
    double w;
    Edge() {}
    Edge(int a,double b,int c):from(a),w(b),to(c) {}
} Edge;
Edge eg;
vector<Edge>edges;                //边集合
vector<int>s[1000];                 //建立邻接表
int in[1000];
double d[1000];
bool vis[1000];
void init()                                    //清空邻接表
{
    for(int i=0; i<=n; i++)
        s[i].clear();
    edges.clear();
}
void add(int from,double w,int to)    //建图
{
    edges.push_back(Edge(from,w,to));
    int len=edges.size();
    s[from].push_back(len-1);
}
int SPFA()
{
    memset(vis,0,sizeof(vis));
    memset(d,0,sizeof(d));          //判断正环所以所有距离清成0,如果是判断负环,则所有距离清成最大值
    memset(in,0,sizeof(in));
    queue<int>q;
    q.push(1);
    d[1]=1;
    int u,to;
    double w;
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        vis[u]=0;
        int len=s[u].size();
        for(int i=0; i<len; i++)
        {
            Edge eg=edges[s[u][i]];
            to=eg.to;
            w=eg.w;
            if(d[to]<d[u]*w)
            {
                d[to]=d[u]*w;
                if(!vis[to])
                {
                    in[to]++;
                    if(in[to]==n)
                        return 1;
                    q.push(to);
                    vis[to]=1;
                }
            }
        }

    }
    return 0;
}
int main()
{
    //freopen("lalala.text","r",stdin);
    char  from[50],to[50];
    string a,b;       //map里边存入的是string,所以当你将字符串存入到char数组里时要记得转换
    int m;
    double w;
    int cnt=1;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        for(int i=1; i<=n; i++)
        {
            scanf("%s",to);
            a=to;
            mp[a]=i;
        }
        init();
        scanf("%d",&m);
        for(int i=0; i<m; i++)
        {
            scanf("%s %lf %s",from,&w,to);
            a=from;
            b=to;
            add(mp[a],w,mp[b]);
        }
        printf("Case %d: %s\n",cnt++,SPFA()?"Yes":"No");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值