EXTENDED LIGHTS OUT【高斯消元】

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:
1. It does not matter what order the buttons are pressed.
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.

题意:有一个5行6列的大方格,每个小方格里都有一盏灯,当你去改变其中一盏灯的状态时,它周围(上下左右)的灯也会改变状态,即亮着的灯会被关掉,关掉的灯会被打开。为了使所有的灯都被关掉,问哪些灯需要被改变状态。

思路:最简单的高斯消元运用,该题只有唯一解,所有不用考虑其他情况。即每盏灯的状态是否需要被改变为方程的一个变元,根据题意列方程组,解出方程组,每个变元相应的解即为答案。


Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

<span style="font-size:18px;">#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#define maxn 35
using namespace std;
int a[maxn][maxn],x[maxn];          //a[]数组存储方程组的系数,x[]数组存储每个变元的解
int equ,var;                                    //equ表示方程的个数,var表示解的个数
int Gauss()
{
    int max_r,k,col;
    for(k=0,col=0; k<equ&&col<var; k++,col++)
    {
        max_r=k;
        for(int j=k+1; j<equ; j++)         //寻找该列最大值所在的行
        {
            if(abs(a[j][col])>abs(a[max_r][col]))
                max_r=j;
        }
        if(max_r!=k)                              //如果存在,则进行行交换
        {
            for(int j=col; j<var+1; j++)
                swap(a[k][j],a[max_r][j]);
        }
        for(int i=k+1; i<equ; i++)          //寻找该列有值的行进行合并同类项
        {
            if(a[i][col])
            {
                for(int j=col; j<var+1; j++)
                    a[i][j]^=a[k][j];
            }
        }
    }
    for(int i=var-1; i>=0; i--)                 //求解
    {
        x[i]=a[i][30];
        for(int j=i+1; j<var; j++)
        {
            x[i]^=(a[i][j]&x[j]);
        }
    }
    return 0;
}
void init()
{
    memset(a,0,sizeof(a));
    memset(x,0,sizeof(x));
    equ=30;
    var=30;
    for(int i=0; i<5; i++)
        for(int j=0; j<6; j++)
        {
            int t=i*6+j;
            a[t][t]=1;                                //本身系数为1
            if(i>0)a[(i-1)*6+j][t]=1;           //与它相关的合法的变元的系数也为1
            if(i+1<5)a[(i+1)*6+j][t]=1;
            if(j>0)a[i*6+j-1][t]=1;
            if(j+1<6)a[i*6+j+1][t]=1;
        }
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int k=1;k<=t;k++)
    {
        init();
        for(int i=0; i<5; i++)
            for(int j=0; j<6; j++)
            {
                scanf("%d",&a[i*6+j][30]);        //每个变元的最初状态
            }
        Gauss();
        printf("PUZZLE #%d\n",k);
        for(int i=0; i<5; i++)
            for(int j=0; j<6; j++)
            {
                printf("%d%c",x[i*6+j],j==5?'\n':' '); 
            }
    }
    return 0;
}</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值