Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 34570 | Accepted: 10705 |
Description
Your task is to calculate d(A).
Input
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
Output
Sample Input
1 10 1 -1 2 2 3 -3 4 -4 5 -5
Sample Output
13
Hint
Huge input,scanf is recommended.
Source
题目:给定一个数组,选择两个不重叠连续子数组,使得这两个子数组之和最大。
思路:由于这两个子数组不重叠,故第一个子数组的最后一个元素的下标至少比第二个子数组的第一个元素的下标小1。因此,可以将数组分成i-1左侧的区域(包括i-1)以及i右侧的区域(包括i),分别求这两侧区域的最大连续子数组和,然后求二者最大和返回。
代码如下:
#include<iostream>
using namespace std;
int a[50005];
int left[50005];
int right[50005];
int main()
{
int t,n,sum_left=0,sum_right=0,max=-20000,max_left=-20000,max_right=-20000;
cin>>t;
while(t--)
{
cin>>n;
for(int i=0;i<n;i++)
cin>>a[i];
for(int i=1;i<n;i++)
{
sum_left=0,sum_right=0;
max_right=-20000;
for(int j=0;j<=i-1;j++)//求a(i-1)左边区域的最大连续子数组和(包括a(i-1))
{
sum_left+=a[j];
if(sum_left<0)//以a(j)结尾的最大连续子数组和
sum_left=0;
if(sum_left>max_left)
max_left=sum_left;
}
for(int k=n-1;k>=i;k--)
{
sum_right+=a[k];
if(sum_right<0)
sum_right=0;
if(sum_right>max_right)
max_right=sum_right;
}
cout<<"i "<<i<<"max_left "<<max_left<<"max_right "<<max_right<<endl;
if(max_left+max_right>max)
max=max_left+max_right;
}
cout<<max<<endl;
}
return 0;
}