HDU 3501 Calculation 2 (欧拉函数)


  
  
C - Calculation 2
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input

For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output

For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input

       
       
3 4 0
 

Sample Output

       
       
0 2
 



简单思路:首先用一下欧拉函数Eluar(n)求一下1-n中与n互质的质因子的个数,然后就要用到下面简单的定理了:如果gcd(n,i)==1,那么就有gcd(n,n-i)==1;

于是题目的要求是要求小于n并且与n不互质的所有数的和,这里我们可以先求与n互质的所有数的和为sum=n*Eular(n)/2 (这里用到了上面的定理)。最后所有数的和 (n-1)*n/2 减去 sum 即可。



//User: ZXPxx
//Memory: 1604 KB		Time: 0 MS
//Language: C++		Result: Accepted

#include<cstdio>
const int mod=1000000007;
int eular(int n)
{
    int cnt=1,i;
    for(i=2;i*i<=n;i++)
        if(n%i==0)
    {
        cnt*=i-1;
        n/=i;
        while(n%i==0)
        {
            n/=i;
            cnt*=i;
        }
    }
    if(n>1)
        cnt*=(n-1);
    return cnt;
}
int main()
{
    __int64 n;
    while(~scanf("%I64d",&n),n)
    {
        __int64 ans=(n-1)*n/2;
        __int64 sum=n*eular(n)/2;
        ans-=sum;
        printf("%I64d\n",ans%mod);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值