1808:最长字符串

1808:最长字符串


Descriotion


算法训练 最长字符串

时间限制:1.0s    内存限制:512.0MB



求出5个字符串中最长的字符串。每个字符串长度在100以内,且全为小写字母。


样例输入

one  two  three  four  five

样例输出

three


input


output


source


#include<iostream>
#include<string>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    char ch[5][101];
    int i,max ;
    int n[5];
    for(i=0;i<5;i++)
    {
       scanf("%s",ch[i]);
        n[i]=strlen(ch[i]);
    }
    max=0 ;
    for(i=1;i<5;i++)
    {
        if(n[max]<n[i])
        {
            max=i ;
        }
    }
    cout<<ch[max];
  return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值