1020:排序问题2

1020:排序问题2


Description


将十个数进行从小到大的顺序进行排列。


Input


十个整数。


Output


以从小到大的顺序输出这十个数,每一个数末尾都有一个空格~


Sample Input


1  2  3  4  5  6  7  8  9  10


Sample Output


10  9  8  7  6  5  4  3  2  1


Source


#include<iostream>
using namespace std;
int main()
{
    int a[100];
    int i,s,temp,index;
    for(i=0; i<10; i++)
    {
       cin>>a[i];
    }
    for(i=0; i<9; i++)
    {
        index=i;
        for(s=i+1; s<10; s++)
            if(a[s]>a[index])
                index=s;
        if(index!=i)
        {
            temp=a[i];
            a[i]=a[index];
            a[index]=temp;
        }
    }
    for(i=0; i<10; i++)
       {
 cout<<a[i]<<" ";
      }
 
    return 0;




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值