1526:这个月有多少天

1526:这个月有多少天


Description


输入年月,判断这年的 这个月有多少天?

注意闰年。


Input


年月 y  m。


Output


天数


d


Sample Input


2015  2


Sample Output


28


#include<iostream>
using namespace std;
int main()
{
 
    int y,m;
    cin>>y>>m;
   if(y%4==0&&y%100!=0||y%400==0)
    {
        if(m==1||m==3||m==5||m==7||m==8||m==10||m==12)
           {
            cout<<"31";
           return 0;
           }
        if(m==2)
            cout<<"29";
        else
            cout<<"30";
    }
    else
    {
       if(m==1||m==3||m==5||m==7||m==8||m==10||m==12)
            {
            cout<<"31";
            return 0;
            }
        if(m==2)
            cout<<"28";
        else
            cout<<"30";
    }
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值