1021:数字母

1021:数字母


Description


输入一个字符串,数出其中的字母的个数。


Input


一个字符串。不包含空格(长度小于100)。


Output


字符串中字母的个数。


Sample INput


124lfdk54AIEJ92854&%$GJ


Sample Output


10


#include<stdio.h>
#include<string.h>
void count(char str[],int *p);
int main()
{
  char ch[80];
  int sum=0;
  gets(ch);
  count(ch,&sum);
  printf("%d\n",sum);
  return 0;
}
void count(char str[],int *p)
{
    int count1=0;
    int i;
   int n;
   n=strlen(str);
    for(i=0;i<n;i++)
    {
        if('A'<=str[i]&&str[i]<='z'||'a'<=str[i]&&str[i]<='z')
            count1++;
    }
*p=count1;
return;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值