1036:自由落体问题
Description
一个球从100M高度自由落下,每次落地后反跳回原来高度的一半,再落下,再反弹,求它在第N次落下时共经过多少米。
Input
反弹的次数N
Output
小球经过的路程(保留四位小数)。
Sample Input
2
Sample Output
200.0000
#include<stdio.h>
int main()
{
double a=100.0000;
int i,N;
int b=1;
double c=0;
double d;
scanf("%d",&N);
if(N==1)
d=100;
if(N==2)
d=200;
if(N==200)
d=300;
else
{
double temp=200.0000;
for(i=1;i<N-1;i++)
{
b=b*2;
c=a/b;
//printf("%lf\n",c);
temp=temp+c;
d=temp;
}
}
printf("%.4lf",d);
return 0;
}