Description
实现public static boolean isSorted(int[] table)
判断整数数组元素是否已经按升序排序。
Input
一列数,需要判断的数组元素。
Output
如果已经排序输出YES
如果没有排序输出NO
Sample Input
1
2
3
4
5
6
2
3
4
5
6
Sample Output
YES
HINT
Source
#include<bits/stdc++.h>
using namespace std;
void panduansort(int table[],int count)
{
int temp=1;
for(int i=0;i<count-1;i++)
{
if(table[i]>=table[i+1])
{
cout<<"NO";
temp=0;
return;
}
}
if(temp==1)
cout<<"YES";
}
int main()
{
int a[100]={0},x,temp=0;
while(cin>>x)
{
a[temp]=x;
temp++;
}
panduansort(a,temp);
return 0;
}