判断升序

33 篇文章 0 订阅
9 篇文章 0 订阅

Description

实现public static boolean isSorted(int[] table)

判断整数数组元素是否已经按升序排序。

Input

一列数,需要判断的数组元素。

Output

如果已经排序输出YES

如果没有排序输出NO

Sample Input

1
2
3
4
5
6

Sample Output

YES

HINT

Source

#include<bits/stdc++.h>
using namespace std;

void panduansort(int table[],int count)
{
     int temp=1;
    for(int i=0;i<count-1;i++)
    {
        if(table[i]>=table[i+1])
           {
            cout<<"NO";
            temp=0;
        return;
           }
    }
    if(temp==1)
        cout<<"YES";
}
int main()
{
    int a[100]={0},x,temp=0;
    while(cin>>x)
    {
        a[temp]=x;
        temp++;
    }
    panduansort(a,temp);
   return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值