poj1703 Find them, Catch them [并查集]

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23300 Accepted: 6960

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.
 
 
题目分析:
 又是一道并查集,第一次看的时候没有头绪,做完1182的食物链后 这就是他的缩小版,但要注意在合并时要判断这两点是否已经属于同一集合,要不然会出现MLE(find 用递归写时)或者TLE(find 用迭代写),因为当两者的根节点相同,会使tree[x]=x,从而在find时进入无限循环.但若是根节点用其自身就无所谓了.
 
 代码:
 #include<iostream>
#include<cstdio>
#define N 100005
using namespace std;
int n,m;
int tree[N];
char kind[N];
int find(int x)
{
    if(tree[x]<=0) return x;
    int t=tree[x];
    tree[x]=find(tree[x]);
    kind[x]=(kind[x]+kind[t])%2;
    return tree[x];
}
void union_set(int a,int b)
{
    int x,y;
    x=find(a);
    y=find(b);
    if(x==y) return;
    if(tree[x]<=tree[y])
    {
        tree[x]=tree[x]+tree[y];
        tree[y]=x;
        kind[y]=(kind[b]+1+kind[a])%2;
    }
    else
    {
        tree[y]=tree[x]+tree[y];
        tree[x]=y;
        kind[x]=(kind[b]+1+kind[a])%2;
    }


}
void init()
{
    for(int i=1; i<=n; i++)
    {
        tree[i]=0;
        kind[i]=0;
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    int T,x,y;
    char c;
    scanf("%d",&T);


    while(T--)
    {
        scanf("%d%d",&n,&m);
         getchar();
        init();
        for(int i=0; i<m; i++)
        {
            scanf("%c%d%d",&c,&x,&y);
         getchar();
            if(c=='D')
            {
                union_set(x,y);
                continue;
            }
            else if(c=='A')
            {  
                if(find(x)==find(y))
                {
                    if(kind[x]==kind[y])
                    printf("In the same gang.\n");
                    else
                    printf("In different gangs.\n");
                }
                else printf("Not sure yet.\n");
            }
        }
    }
    return 0;
}

                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值