poj2018 Best Cow Fences(二分)

Best Cow Fences

Description

Farmer John’s farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000.

FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input.

Calculate the fence placement that maximizes the average, given the constraint.
Input

  • Line 1: Two space-separated integers, N and F.

  • Lines 2..N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on.
    Output

  • Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields.
    Sample Input

10 6
6
4
2
10
3
8
5
9
4
1
Sample Output

6500

题意:给定一个正整数列,求一个平均数最大的、长度不小于L的子段。

分析:二分答案mid,把数列每个数减去mid,根据最大子序列是否大于0调整l,r

代码

#include <cstdio>
#include <iostream>
#define N 100005
#define inf 1e10
#define eps 1e-5
using namespace std;

double a[N],sum[N];
int n,m;

bool check(double x)
{
    for (int i = 1; i <= n; i++)
        sum[i] = sum[i - 1] + (a[i] - x);
    double min = inf;
    double max = -inf;
    for (int i = m; i <= n; i++)
    {
        if (sum[i - m] < min) min = sum[i - m];
        if (sum[i] - min > max) max = sum[i] - min;
    }
    if (max >= 0) return true;
    return false;
}

int main()
{
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++)
        scanf("%lf", &a[i]);
    double l,r;
    l = 0; r = 1e6;
    while (r - l > eps)
    {
        double mid = (l + r) / 2;
        if (check (mid)) l = mid;
            else r = mid;
    }
    cout << int(r*1000) << endl;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值