poj3263 Tallest Cow(前缀和+hash)

Tallest Cow

Description

FJ’s N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form “cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

Line 1: Four space-separated integers: N, I, H and R
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.
Output

Lines 1..N: Line i contains the maximum possible height of cow i.
Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8
Sample Output

5
4
5
3
4
4
5
5
5

题意:N头牛站成一排,当两头牛中间的牛身高都比他们矮时,它们能互相看见,现在只知道第P头牛身高为H,以及M对关系,每对ai,bi说明ai,bi能互相看见,求每头牛最大可能身高。

分析:对于每对ai,bi,将它们之间牛的高度都减1,表明它们的身高至少要比ai,bi小1,最后每头牛加上H即可。但是朴素算法会超时,差分一下,将区间修改变成端点修改,注意要对ai,bi判重。

代码

#include <cstdio>
#define N 10005
#define ll long long
#define mo 1000007
using namespace std;

ll hash[mo];
int a[N],b[N],n,m,h;

void exchange(int &x, int &y)
{
    int t = x;
    x = y;
    y = t;
}

int has(ll x)
{
    int tmp = x % mo;
    while (hash[tmp]!=0 && hash[tmp]!=x) tmp = (tmp + 1) % mo;
    return tmp;
}

int main()
{
    int p;
    scanf("%d%d%d%d", &n, &p, &h, &m);
    for (int i = 1; i <= m; i++)
    {
        int x, y;
        scanf("%d%d", &x, &y);
        if (x > y) exchange(x, y);
        ll t = x * 233 + y * 577;
        int ha = has(t);
        if (hash[ha] == t) continue;
           else hash[ha] = t;
        a[x+1] -= 1;
        a[y] += 1;
    }
    for (int i = 1;i <= n; i++)
    {
        b[i] = b[i-1] + a[i];
        printf("%d\n", h + b[i]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值