Radar Installation
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
题意:已知N个点坐标,雷达只能建在x轴,每个雷达监控范围均为半径为R的圆形,求监控所有点需要的最少雷达数,若无法监控所有点输出-1。
分析:通过雷达半径R可以求出每个点在x轴上能放雷达的有效范围,即一个区间,然后问题转化为,在x轴放最少的点使每个区间中至少有一个点。贪心:尽可能放在靠后的位置。
代码
#include <cstdio>
#include <algorithm>
#include <cmath>
#define N 1005
using namespace std;
struct arr
{
double l,r;
}a[N];
int n;
double r;
int cmp(arr x, arr y)
{
return x.l < y.l;
}
int main()
{
int num = 0;
while (~scanf("%d%lf", &n, &r))
{
num++;
double x,y;
bool fl = false;
int maxy = 0;
if (n == 0) break;
for (int i = 1; i <= n; i++)
{
scanf("%lf%lf", &x, &y);
if (fabs(y) > r) fl=true;
double dis;
if (y * y <= r * r) dis = sqrt(r * r - y * y);
a[i].l = x - dis;
a[i].r = x + dis;
}
if (fl){printf("Case %d: -1\n", num);continue;}
sort(a+1, a+n+1, cmp);
double pos = a[1].r;
int cnt = 1;
for (int i = 2; i <= n; i++)
{
if (a[i].l > pos)
{
cnt++;
pos = a[i].r;
}
else if (pos > a[i].r) pos = a[i].r;
}
printf("Case %d: %d\n", num, cnt);
}
}