Summer Online Training Camp 1 for ICPC Training League (Recursion & Backtracking)

A POJ 1664 放苹果

传送门: link.
Description

把M个同样的苹果放在N个同样的盘子里,允许有的盘子空着不放,问共有多少种不同的分法?(用K表示)5,1,1和1,5,1 是同一种分法。

Input

第一行是测试数据的数目t(0 <= t <= 20)。以下每行均包含二个整数M和N,以空格分开。1<=M,N<=10。

Output

对输入的每组数据M和N,用一行输出相应的K。

Sample Input

1
7 3

Sample Output

8

题解

递归,有以下几种情况:
当m = 1,f(1,n) = 1;将一个苹果放在n个盘子里,只有一种放法;

当n = 1,f(m,1) = 1;将m个苹果放在1个盘子里,只有一种方法;

当m = n,f(m,n) = f(m,n-1)+1;每个盘子里都放苹果,或者至少有一个盘子里不放苹果;

当m < n, f(m,n) = f(m,m);只能把m个苹果放进m个盘子里;

当m > n,f(m,n) = f(m,n-1)+f(m-n,n);每个盘子里都放苹果,先把n个苹果抽出来放进n个盘子里,剩下m-n个苹果放进n个盘子里;或者至少一个盘子里不放。

#include<stdio.h>
int fun(int m,int n)
{
   
	if(m==0||n==1)
		return 1;
	if(m<n)
		return fun(m,m);
	else
		return fun(m,n-1)+fun(m-n,n);
}
int main()
{
   
	int t,m,n;
	scanf("%d",&t);
	while(t--)
	{
   
		scanf("%d%d",&m,&n);
		printf("%d\n",fun(m,n));
	}
	return 0;
}

B POJ 2013 Symmetric Order

传送门: link.
Description

In your job at Albatross Circus Management (yes, it’s run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc.

Input

The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.

Output

For each input set print “SET n” on a line, where n starts at 1,
followed by the output set as shown in the sample output.

Sample Input

7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0

Sample Output

SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan
Bill

题解

递归实现

#include<iostream>
using namespace std;
void fun(int n)
{
   
	string s;
	cin>>s;
	cout<<s<<endl;
	if(--n)
	{
   
		cin>>s;
		if(--n)
			fun(n);
		cout<<s<< endl;
	}
}
int main()
{
   
	int n,cas=1;
	while(cin>>n&&n)
	{
   
		cout<<"SET "<<cas++<<endl;
		fun(n);
	}
	return 0;
}

不用递归的方法

#include<stdio.h>
int main()
{
   
	char str[100][100];
	int n,i,head,tail,cas=1;
	while(~scanf("%d",&n)&&n)
	{
   
		head=0;
		tail=n-1;
		for(i=0; i<n; i++)
		{
   
			if(i%2==0)
				scanf("%s",str[head++]);
			else
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值