Heavy Transportation 最短路

题目:

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

输入:

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

输出:

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

样例输入:

1
3 3
1 2 3
1 3 4
2 3 5

样例输出:

Scenario #1:
4

这个题目的意思是要从城市1到城市N运送货物,有M条道路,每条道路都有它的最大载重量,问从城市1到城市N运送最多的重量是多少。每条路的最大载重量取决于这条路上权值最小的边,因为如果权值再大的边,如果权值最小的那条边过不去的话,这条路是走不通的。我们要求的就是这些路中最大承载量的最大值,也就是先求出没条边最短的,最后取这些短的中最长的那一条。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1e6+5;
int Map[1111][1111];
bool vis[1111];
int dis[maxn];//这里把maxn换成1111也对
int n,m;
void dijkstra(int q)
{
    int minv;
    memset(vis,0,sizeof(vis));
     for(int i=1;i<=n;i++)
            dis[i]=Map[1][i];

        for(int i=1;i<=n;i++)
        {
            minv=0;
            int k;
            for(int j=1;j<=n;j++)
            {
                if(!vis[j]&&dis[j]>minv)//每次让载重量尽可能的大
                {
                    minv=dis[j];
                    k=j;
                }
            }
            vis[k]=1;
            for(int j=1;j<=n;j++)
            {
                dis[j]=max(min(dis[k],Map[k][j]),dis[j]);//这就是说的先求每条路自己权值最小的出来,然后再求这些最短的当中最大的
            }
        }
        return ;
}
int main()
{
    int s;
    int cas=1;
    scanf("%d",&s);
    while(s--)
    {
        scanf("%d%d",&n,&m);
        memset(Map,0,sizeof(Map));//这里如果用两个for循环的话,提交会runtime error
        for(int i=1;i<=m;i++)
        {
            int a,b,w;
            scanf("%d%d%d",&a,&b,&w);
            if(w>0)
                Map[a][b]=Map[b][a]=w;
        }
       dijkstra(1);
        printf("Scenario #%d:\n%d\n\n",cas++,dis[n]);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值