POJ 3630 Phone List 字典树

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

 

给出n个字符串,问其中一个是不是其他的前缀,如果是,输出NO,否则输出YES

注意在查找的时候查找到字符串的倒数第二位就可以了,如果查到倒数第一位的话,就会把自身也算上,这样无论怎样最后都会输出NO了。

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <string>
#include <map>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=2e6+190;
int tire[maxn][15];
bool vis[maxn];
int tot;
void Insert(char *s)
{
    int len=strlen(s);
    int rt=0;
    for(int i=0;i<len;i++)
    {
        int id=s[i]-'0';
        if(!tire[rt][id])
            tire[rt][id]=++tot;
        rt=tire[rt][id];
    }
    vis[rt]=true;
}
int Find(char *s)
{
    int len=strlen(s);
    int rt=0;
    for(int i=0;i<len-1;i++)//查找到字符串的倒数第二位
    {
        int id=s[i]-'0';        
        rt=tire[rt][id];
        if(vis[rt])return true;
    }
    return false;
}
char ss[10010][12];
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",ss[i]);
            Insert(ss[i]);
        }
        int flag=0;
        for(int i=0;i<n;i++)
        {
            if(Find(ss[i]))
            {
                flag=1;
                break;
            }
        }
        if(flag==0)
            printf("YES\n");
        else
            printf("NO\n");
        for(int i=0;i<=tot;i++)//因为tire数组,vis数组,tot都是全局变量,所以一次while完成后要重新初始化
        {
            vis[i]=false;
            for(int j=0;j<10;j++)
                tire[i][j]=0;
        }
        tot=0;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值