The sum problem

Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
Output
For each test case, print all the possible sub-sequence that its sum is M. The format is show in the sample below. If no sub-sequence exists, it need not print any infomation.  Print a blank line after each test case.
Sample Input
20 10
50 30
0 0
Sample Output
[1,4]
[10,10]


[4,8]
[6,9]
[9,11]
[30,30]


如果用暴力求解,由于数据量比较的大,时间复杂度为O(n2),会超时。

仔细观看题目:有等差数列可以得2 * max = (i + j) * (j-i+1);

设i+j = a,j-i+1=b,解得:j = (a + b -1) / 2,i = (a-b +1)/2。其中a和b为2*m的因子。

所以我们只需要求2*m的因子即可。时间复杂度为O(sqrt(2*m))为线性阶时间复杂度。

package _5;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner input = new Scanner (System.in);
		while (true) {
			int n = input.nextInt();
			int m = input.nextInt();
			if (n ==0 && m == 0) {
				break;
			}
			m = 2 * m;
			int c1,c2;
			int max = (int)Math.sqrt(1.0 * m);
			for (int i = max;i >= 1;i--) {
				if (m % i == 0) {
					int t = m / i;
					if ((t + i - 1) % 2 == 0 && (t - i + 1) % 2 == 0 ) {
						c2 = (t + i - 1) / 2;
						c1 = (t- i + 1) / 2;
						if (c2 > n) {
							break;
						}
						System.out.println("["+c1+","+c2+"]");
					}
				}
			}
			System.out.println();
		}
	}
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值