【算法设计】
这题用等差数列来计算
先求数列的长度
Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
Sample Input
20 10 50 30 0 0
Sample Output
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
int n,m,len,a;
while(scanf("%d%d",&n,&m)&&n&&m)
{
len=sqrt(double(m*2))+1;
while(--len)
{
a=m/len-(len-1)/2;
//m=(a+a+len-1)*len/2
if((a+a+len-1)*len/2==m)
{
printf("[%d,%d]\n",a,a+len-1);
}
}
printf("\n");
}
return 0;
}