HDU 2058

【算法设计】

这题用等差数列来计算

先求数列的长度

Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input
 
 
20 10 50 30 0 0

Sample Output
 
 
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
    int n,m,len,a;
    while(scanf("%d%d",&n,&m)&&n&&m)
    {
        len=sqrt(double(m*2))+1;
        while(--len)
        {
            a=m/len-(len-1)/2;
            //m=(a+a+len-1)*len/2
            if((a+a+len-1)*len/2==m)
            {
                printf("[%d,%d]\n",a,a+len-1);
            }
        }
        printf("\n");
    }
    return 0;
}

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值