nyoj 592 spiral grid

spiral grid

时间限制:2000 ms  |  内存限制:65535 KB

难度:4

描述

Xiaod has recently discovered the grid named "spiral grid".
Construct the grid like the following figure. (The grid is actually infinite. The figure is only a small part of it.)

 



Considering traveling in it, you are free to any cell containing a composite number or 1, but traveling to any cell containing a prime number is disallowed. In addition, traveling from a prime number is disallowed, either. You can travel up, down, left or right, but not diagonally. Write a program to find the length of the shortest path between pairs of nonprime numbers, or report it's impossible.

 

输入

Each test case is described by a line of input containing two nonprime integer 1 <=x, y<=10,000.

输出

For each test case, display its case number followed by the length of the shortest path or "impossible" (without quotes) in one line.

样例输入

1 4

9 32

10 12

样例输出

Case 1: 1

Case 2: 7

Case 3: impossible

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int map[105][105]={0};
int mm=10000,n=100;
int fir,end,loop[105][105];
int prime[11000]={1,1,0};
int sx[]={0,0,1,-1},zy[]={1,-1,0,0};
void Build_map() //建立地图
{
    int i,j,k;
    for(i=1;i<=(n+1)/2;i++)
    {
        for(j=1;j<=n-2*i+2;j++)
            map[i][j+i-1]=mm--;
        for(j=1;j<=n-2*i;j++)
           map[j+i][n-i+1]=mm--;
        for(j=n-i+1;j>=i;j--)
           map[n-i+1][j]=mm--;
        for(j=n-i;j>=i+1;j--)
           map[j][i]=mm--;
    }
}
void printf_map()//打印地图
{
    int i,j;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
          printf("%d ",map[i][j]);
        printf("\n");
    }

}
void judge_prime()  //筛选法打个素数表
{
    int i,j;
    for(i=2;i<=10000;i++)
    {
        if(prime[i]==0)
        {
            for(j=i+i;j<=10000;j+=i)
              prime[j]=1;
        }
    }
}
struct coordinate
{
    int x;
    int y;
    int step;
}t1;
void find() //找到 fir 的坐标,存在 t1 中
{
    int i,j;
    for(i=1;i<=n;i++)
      for(j=1;j<=n;j++)
      {
          if(map[i][j]==fir)
          {
              t1.x=i;
              t1.y=j;
              loop[i][j]=1;
              t1.step=0;
              return;
          }
      }
}
int bfs()
{
    int i,j,step,x,y;
    queue<coordinate> Q;
    Q.push(t1);
    while(!Q.empty())
    {
        i=Q.front().x;
        j=Q.front().y;
        step=Q.front().step;
        Q.pop();
        if(map[i][j]==end)
          return step;
        for(int a=0;a<4;a++)
        {
            x=i+sx[a];
            y=j+zy[a];
            if(map[x][y]!=0&&prime[map[x][y]]==1&&loop[x][y]==0)
            {
                coordinate t2={x,y,step+1};
                Q.push(t2);
                loop[x][y]=1;
            }
        }
    }
    return 0;
}
int main()
{
    int i,j,nn=0;
    Build_map();
    judge_prime();
    //printf_map();
    while(~scanf("%d%d",&fir,&end))
    {
        nn++;
        memset(loop,0,sizeof(loop));
        find();
        int ans=bfs();
        if(ans)
            printf("Case %d: %d\n",nn,ans);
        else
            printf("Case %d: impossible\n",nn);
    }
}

  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于C++&OPENCV 的全景图像拼接 C++是一种广泛使用的编程语言,它是由Bjarne Stroustrup于1979年在新泽西州美利山贝尔实验室开始设计开发的。C++是C语言的扩展,旨在提供更强大的编程能力,包括面向对象编程和泛型编程的支持。C++支持数据封装、继承和多态等面向对象编程的特性和泛型编程的模板,以及丰富的标准库,提供了大量的数据结构和算法,极大地提高了开发效率。12 C++是一种静态类型的、编译式的、通用的、大小写敏感的编程语言,它综合了高级语言和低级语言的特点。C++的语法与C语言非常相似,但增加了许多面向对象编程的特性,如类、对象、封装、继承和多态等。这使得C++既保持了C语言的低级特性,如直接访问硬件的能力,又提供了高级语言的特性,如数据封装和代码重用。13 C++的应用领域非常广泛,包括但不限于教育、系统开发、游戏开发、嵌入式系统、工业和商业应用、科研和高性能计算等领域。在教育领域,C++因其结构化和面向对象的特性,常被选为计算机科学和工程专业的入门编程语言。在系统开发领域,C++因其高效性和灵活性,经常被作为开发语言。游戏开发领域中,C++由于其高效性和广泛应用,在开发高性能游戏和游戏引擎中扮演着重要角色。在嵌入式系统领域,C++的高效和灵活性使其成为理想选择。此外,C++还广泛应用于桌面应用、Web浏览器、操作系统、编译器、媒体应用程序、数据库引擎、医疗工程和机器人等领域。16 学习C++的关键是理解其核心概念和编程风格,而不是过于深入技术细节。C++支持多种编程风格,每种风格都能有效地保证运行时间效率和空间效率。因此,无论是初学者还是经验丰富的程序员,都可以通过C++来设计和实现新系统或维护旧系统。3

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值