Hdu1196 Lowest Bit

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12215    Accepted Submission(s): 8916

Problem Description

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

 

 

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

 

 

Output

For each A in the input, output a line containing only its lowest bit.

 

 

Sample Input

26

88

0

 

 

Sample Output

2

8

#include<stdio.h> 
int main()  
{  
    int num,sum,i,j,temp;  
    while(scanf("%d",&num)&&num!=0)  
    {  
        sum=1;temp=0;  
        for(i=1;temp==0;i++)  
        {  
            temp=num%2;  
            num=num/2;  
        }  
        for(j=1;j<i-1;j++)  
        	sum=sum*2;  
        printf("%d\n",sum);
    }  
    return 0;  
}  

  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值