hdu4786Fibonacci Tree

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 38    Accepted Submission(s): 21


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4790  4789  4787  4785  4784 
 

Statistic |  Submit |  Discuss |  Note


题意:给你一些白色跟黑色的边,问你在这幅图里能不能找出一个生成树且里面的白边数量是Fibonacci数列的数

分析:找出白边最少的生成树和白边最多的生成树的情况,然后看在这之间有没有Fibonacci数,如果有就是yes啦,没有就no

为什么呢?因为生成树是n-1条边,如果你删除一条黑边,必然会孤立一个点,所以你要另一条边来连接这一个点,如果有白边就直接连这种情况就是

白边加一了,如果没有白边连出去,那可以知道这个点是没有任何的白边连到其他边。所以最多边的那副生成树也不会有这种情况,所以一定会出现中间的生成树。

还要用到并查集来判断是否在一个集合。。


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[100005];
int fa[100005];
struct node
{
	int x,y;
	int t;
}node[100005];
bool cmp(struct node a,struct node b)
{
	return a.t<b.t;
}
void Init()
{
	memset(f,0,sizeof(f));
	int l=1,r=2,var;
	f[1] = f[2] = 1;
	while(l+r<100002)
	{
		f[l+r] = 1;
		var = l;
		l = r;
		r = var+r;
	}
}
int find(int x)
{
	return fa[x]==x?x:(fa[x] = find(fa[x]));
}
int findl(int n,int m)
{
	for(int w=0;w<=n;w++)
		fa[w] = w;
	int ans = 0;
	for(int i=0;i<m;i++)
	{
		int xx = find(node[i].x);
		int yy = find(node[i].y);
		if(xx==yy)
			continue;
		fa[xx] = yy;
        ans+=node[i].t;
	}
	int z = find(1);
	for(int j=2;j<=n;j++)
		if(find(j)!=z)
			return 0;
		
		return ans;		
}
int findr(int n,int m)
{
	for(int w=0;w<=n;w++)
		fa[w] = w;
	int ans = 0;
	for(int i=m-1;i>=0;i--)
	{
		int xx = find(node[i].x);
		int yy = find(node[i].y);
		if(xx==yy)
			continue;
		fa[xx] = yy;
        ans+=node[i].t;
	}
	int z = find(1);
	for(int j=2;j<=n;j++)
		if(find(j)!=z)
			return 0;
		
		return ans;		
}
int main()
{
	int n;
	int N,M;
	Init();
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d",&N,&M);
		if(M==0)
		{
			printf("Case #%d: No\n",i);
			continue;
		}
		
		for(int j=0;j<M;j++)
		{
			scanf("%d%d%d",&node[j].x,&node[j].y,&node[j].t);
		}
		
		sort(node,node+M,cmp);
		int l = findl(N,M);
		int r = findr(N,M);
		int FF = 0;
		for(int c=l;c<=r;c++)
			if(f[c]==1)
			{
				FF = 1;
				break;
			}
			if(FF)
				printf("Case #%d: Yes\n",i);
			else
				printf("Case #%d: No\n",i);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值