Java计算数学表达式(字符串形式)

本文介绍如何使用Java编程读取一行包含加减乘除括号的数学表达式,并计算其结果。示例中,输入表达式'(2+32)/2-6',输出结果为11。
摘要由CSDN通过智能技术生成

我的个人博客:zhang0peter的个人博客


题目:
表达式计算II
Write a program that reads an expression in a line as input and prints out the result. Only integers and operators below are allowed in the expression:
( )+ - * / %
输入格式:
A line of expression.
输出格式:
The result.
输入样例:
(2+32)/2-6
输出样例:
11

import java.util.Scanner;
import java.util.Stack;



public class Hello {
   

	   public static void main(String[] args) {
   
           Scanner scanner = new Scanner(System.in);
           String str = scanner.nextLine();
           //double result1 = compute("-3*-3");
            double result1 = compute(str);
           System.out.println((int) result1);
   }

   public static int priority(char s) {
   
           switch (s) {
   
           case '(':
           case ')':
                   return 0;
           case '-':
           case '+':
                   return 1;
           case '*':
           case '%':
           case '/':
                   return 2;
           default:
                   return -1;

           }
   }

   public static double compute(double num1, double num2, char s) {
   
           switch (s) {
   
           case '(':
           case ')':
                   return 0;
           case '-':
                   return num1 - num2;
           case '+':
                   return num1 + num2;
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值