hdoj 2199 寻找等式成立的近似值 (用二分法寻找等式成立的临近点)



二分法的基础应用:

                                  题目如下:

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13005    Accepted Submission(s): 5826


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
      
      
2 100 -4
 

Sample Output
      
      
1.6152 No solutio






            AC码如下




<span style="font-size:14px;">#include<stdio.h>
double fangcheng(double x)   //注意函数定义的时候都必须用double 
{
	double y=8.0*x*x*x*x+7.0*x*x*x+2.0*x*x+3.0*x+6.0;
	return y;
}
double fabs(double m)  //精度函数定义方法 
{
	return m>0?m:-m;  	
}
int main()
{	int n;
	double a;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%lf",&a);
		double right=100.0,left=0.0,mid;
		if(fangcheng(0.0)>a||fangcheng(100.0)<a)		    
		    	printf("No solution!\n");
		else
		{
				while(fangcheng(right)-fangcheng(left)>=1e-5)  //注意精度的选取,尽量大的原则 
			{   
				mid=(left+right)/2.0;
				if(fabs(fangcheng(mid)-a)<=1e-5)
				break;
				else if(fangcheng(mid)<a&&fabs(fangcheng(mid)-a)>1e-5)	
				left=mid; //这个不能使MID-1,只有在数组位置变化的或者整形的时候才加减1!! 
				else
				right=mid;
			}	
			printf("%.4lf\n",mid);
			
		}	
				    				
	}
	return 0;
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值