描述
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.
Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.
输入
The first line of input will contain a single integer T ?C the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N ?C the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces ?C amount of M&Ms of i-th color.
Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747
输出
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.
样例输入
3
3 5 1
1
1
样例输出
Brother
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
int t,n,m,i;
cin >> t;
while(t--)
{
cin>>n;
int s = 0,flag = 0; //flag判断是否是孤单堆
for(i = 0;i < n;i++)
{
cin >> m;
s ^= m;
if (m > 1)
flag = 1;
}
if(flag == 0)
if(n % 2)
cout << "Brother\n";
else
cout << "John\n";
else
if(s == 0)
cout << "Brother\n";
else
cout << "John\n";
}
return 10080;
}