John

描述

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box. 

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

输入

The first line of input will contain a single integer T ?C the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N ?C the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces ?C amount of M&Ms of i-th color. 

Constraints: 
1 <= T <= 474, 
1 <= N <= 47, 
1 <= Ai <= 4747

输出

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

样例输入

2
3
3 5 1
1
1

样例输出

John
Brother


#include <iostream>
#include <cstring>
using namespace std;
int main()
{
    int t,n,m,i;
    cin >> t;
    while(t--)
    {
              cin>>n;
              int s = 0,flag = 0;   //flag判断是否是孤单堆
              for(i = 0;i < n;i++)
              {
                    cin >> m;
                    s ^= m;
                    if (m > 1)
                       flag = 1;
              }
              if(flag == 0)
                      if(n % 2)
                           cout << "Brother\n";
                      else
                           cout << "John\n";
              else
                  if(s == 0)
                       cout << "Brother\n";
                  else
                       cout << "John\n";
    }
    return 10080;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值