Lake Counting (简单深搜)积水问题

 Lake Counting

 

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.


C++代码:

#include<cstdio>
#include<iostream> 
#include<algorithm>
#include<cstring>
using namespace std;

char a[105][105];
int n,m;

void dfs(int x,int y)
{
	a[x][y]='.';
	for(int dx=-1;dx<=1;dx++){
		for(int dy=-1;dy<=1;dy++){
			int nx=x+dx,ny=y+dy;	
			if(nx>=0 && nx<n && ny>=0 && ny<m && a[nx][ny]=='W'){
				dfs(nx,ny);
			}
		}
	}
	return;
}
void slove()
{
	int res=0;
	for(int i=0;i<n;i++){
		for(int j=0;j<m;j++){
			if(a[i][j]=='W'){
				dfs(i,j);
				res++;
			}
		}
	}
	printf("%d\n",res);

}
int main()
{
	int i,j;
	scanf("%d%d",&n,&m);getchar();
	for(i=0;i<n;i++){
		for(j=0;j<m;j++){
			scanf("%c",&a[i][j]);
		}
		getchar();
	}
	slove();
	return 0;
}

Java代码:

import java.math.*;
import java.util.*;

public class Main {
	static int n,m,ans;
	static char [][]filed=new char[105][105];
	public static void main(String[] args) {
		Scanner cin=new Scanner(System.in);
		while(cin.hasNext()){
			n=cin.nextInt();
			m=cin.nextInt();
			String s;
			for(int i=1;i<=n;++i){
				s=cin.next();
				for(int j=1;j<=m;++j){
					filed[i][j]=s.charAt(j-1);
				}
			}
			slove();
			System.out.println(ans);
		}
	}
	private static void slove(){
		ans=0;
		for(int i=1;i<=n;++i){
			for(int j=1;j<=m;++j){
				if(filed[i][j]=='W'){
					dfs(i,j);
					ans++;
				}
			}
		}
	}
	private static void dfs(int x,int y){
		filed[x][y]='.';
		for(int i=-1;i<=1;++i){
			for(int j=-1;j<=1;++j){
				int nx=x+i;
				int ny=y+j;
				if(nx>=1&&nx<=n&&ny>=1&&ny<=m&&filed[nx][ny]=='W')
						dfs(nx,ny);
			}
		}
	}
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值