完全背包

完全背包

 

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
Assume the following bonds are available: 
ValueAnnual
interest
4000
3000
400
250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.
Input
The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.
Output
For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.
Sample Input
1
10000 4
2
4000 400
3000 250
Sample Output
14050


题意:

给出初始资金,还有年数,然后给出每个物品的购买价格与每年获得的利益,要求在给出的年份后所能得到的最大本利之和。

思路:刚开始,我认为这是多重背包,因为我觉得分成每种小包的情况是受限的,比如10000只能最多分成两个4000或者一个4000两个3000,但是,只要当V足够大时,就可以分成无限份小包,因此可以当作完全背包

AC代码:

import java.util.Arrays;
import java.util.Scanner;

public class Main{
	public static void main(String[] args) {  
		Scanner cin=new Scanner(System.in);
		
		int []vol = new int [15];
		int []val = new int [15];
		int []dp  = new int [100010];
		int T = cin.nextInt();
		while(T--!=0){
			int V = cin.nextInt();
			int Y = cin.nextInt();
			int n = cin.nextInt();
			
			for(int i=1; i<=n; ++i){
				vol[i] = cin.nextInt();
				vol[i] = vol[i]/1000;
				val[i] = cin.nextInt();
			}
			
			Arrays.fill(dp, 0);
			dp[0] = 0;
				
			int ans = V;
			for(int y = 1;y <=Y; ++y){	
				V = ans/1000;
				for(int i=1; i<=n; ++i){
					for(int j=vol[i]; j<=V; ++j){
						dp[j] = Math.max(dp[j], dp[j-vol[i]]+val[i]);
					}
				}
				ans += dp[V];
				
			}
			System.out.println(ans);
		}
	 }	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值