River Hopscotch

River Hopscotch

 

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input
Line 1: Three space-separated integers:  LN, and  M 
Lines 2..  N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks
Sample Input
25 5 2
2
14
11
21
17
Sample Output
4
Hint
Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意:起点为0,终点为L,中间有n块石头,求去掉m块石头后剩下的石头的最小间距的最大值。

思路:这道题用了二分的思想,首先假设我们的答案为mid(此案例开始时为12),然后将排序后的各个石头的间距与mid比较,如果其小于mid,说明此石头是应当去除的(因为我们假设mid为最小距离的最大值,一旦有间距小于mid那我们的假设就不成立了),每去除一块石头,count++(count记录去除的石头数)。当循环结束后如果发现count>mid,说明我们去除的石头太多了,应当少去掉一些,因此应当将我们假设的结果mid减少一些,这样不停的通过二分查找,最后剩下的就是我们想要的结果。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
#define maxn 50005
using namespace std;

int pos[maxn];
int l,n,m;
int bsearch(int x,int y)
{
	while(x<=y){
		int mid = x+(y-x)/2;  //mid:当前猜测的答案 
		int count = 0;//记录去掉的石头的个数
		int pre = 0;  //最开始保留的石头的序号 
		for(int i=1;i<=n+1;++i){
			if(pos[i]-pos[pre]<mid)	count++; 
			else	pre = i;
		}
		//与目标进行比较,更改x,y的范围 
		if(count>m)	y = mid-1; 
		else	x = mid+1;
	}
	return y;
}
int main()
{
	while(scanf("%d%d%d",&l,&n,&m)!=EOF){
		for(int i=1;i<=n;++i){
			scanf("%d",&pos[i]);
		}
		pos[0]=0;pos[n+1]=l;
		sort(pos,pos+n+1);
		int ans = bsearch(0,l);
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值