Automatic Judge HDU - 6023 (map)

Welcome to HDU to take part in the second CCPC girls’ competition!
A new automatic judge system is used for this competition. During the five-hour contest time, you can submit your code to the system, then the judge will reply you. Here is a list of the judge's replies and their meaning:

1. Accepted(AC)Accepted(AC): Yes, your program is correct. You did a good job!

2. PresentationError(PE)PresentationError(PE) : Your program's output format is not exactly the same as required by the problem, although the output is correct. This usually means the existence of omitted or extra blank characters (white spaces, tab characters and/or new line characters) between any two non-blank characters, and/or blank lines (a line consisting of only blank characters) between any two non-blank lines. Trailing blank characters at the end of each line and trailing blank lines at the of output are not considered format errors. Check the output for spaces, blank lines, etc. against the problem's output specification.

3. WrongAnswer(WA)WrongAnswer(WA) : Correct solution not reached for the inputs. The inputs and outputs that we use to test the programs are not public (it is recomendable to get accustomed to a true contest dynamic :-)

4. RuntimeError(RE)RuntimeError(RE) : Your program failed during the execution and you will receive the hints for the reasons.

5. TimeLimitExceeded(TLE)TimeLimitExceeded(TLE) : Your program tried to run during too much time.

6. MemoryLimitExceeded(MLE)MemoryLimitExceeded(MLE): Your program tried to use more memory than the judge default settings.

7. OutputLimitExceeded(OLE)OutputLimitExceeded(OLE): Your program tried to write too much information. This usually occurs if it goes into a infinite loop.

8. CompilationError(CE)CompilationError(CE): The compiler fails to compile your program. Warning messages are not considered errors. Click on the judge's reply to see the warning and error messages produced by the compiler.

For each submission, if it is the first time that the judge returns ``AC'' on this problem, then it means you have passed this problem, and the current time will be added to the penalty of your team. In addition, every time you pass a problem, each unsuccessful try for that problem before is counted as 20 minutes penalty, it should also be added to the penalty of your team.
Now given the number of problems in the contest and the submission records of a team. Please write a program to calculate the number of problems the team passed and their penalty.
InputThe first line of the input contains an integer T(1T20)T(1≤T≤20), denoting the number of test cases.
In each test case, there are two integers n(1n13)n(1≤n≤13) and m(1m100)m(1≤m≤100) in the first line, denoting the number of problems and the number of submissions of a team. Problems are labeled by 1001, 1002, ..., 1000+n1000+n.
In the following mm lines, each line contains an integer x(1001x1000+n)x(1001≤x≤1000+n) and two strings t(00:00t05:00)t(00:00≤t≤05:00) and ss, denoting the team submits problem xx at time tt, and the result is ss. tt is in the format of HH:MM, while ss is in the set \{AC, PE, WA, RE, TLE, MLE, OLE\}. The team is so cautious that they never submit a CE code. It is guaranteed that all the tt in the input is in ascending order and every tt is unique.
OutputFor each test case, print a single line containing two integers AA and BB, denoting the number of problems the team passed and the penalty.
Sample Input
1
3 5
1002 00:02 AC
1003 00:05 WA
1003 00:06 WA
1003 00:07 AC
1002 04:59 AC
Sample Output
2 49

题意:模拟oj

坑点:需要考虑00:00 ac,所以在数组写法中要让ac条件为a[num-1000]>=0

map写法:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 110
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 100000000
using namespace std;

map<int ,int> M; //M[1003] = 2;表示题号为1003的题错误次数为2
int T,n,m;
int main()
{
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        M.clear();
        int sum=0;
        int id,x,y;
        char str[10];
        int ans = 0;
        while(m--){
            scanf("%d",&id);
            scanf("%d:%d",&x,&y);
            cin>>str;
            if(M[id]==1)
                continue;
            if(str[0]=='A'){
                sum -= 20*M[id];  //罚时
                M[id] = 1;
                sum += x*60+y;
                ans++;
            }
            else{
                M[id]--;
            }
        }
        cout<<ans<<" "<<sum<<endl;
    }
    return 0;
}

数组写法:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 110
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 100000000
using namespace std;

int T,n,m,a[15],flag[15];
string s;
int main()
{
    scanf("%d",&T);
    while(T--){
        memset(a,-1,sizeof(a));
        memset(flag,0,sizeof(flag));
        int sum=0,ans=0,num,x,y;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;++i){
            cin>>num;
            scanf("%d:%d",&x,&y);
            cin>>s;
            if(a[num-1000]>=0)continue; //说明此题已经ac
            if(s=="AC"){
                sum += 60*x+y+flag[num-1000]*20;
                a[num-1000]=sum;
                ans++;
            }
            else{
                flag[num-1000]++;
            }
        }
        cout<<ans<<" "<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值