Balanced Lineup
For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0
题意:给定n 个奶牛的高度,求给定区间内最高的奶牛和最矮的奶牛的差值。
思路:典型RMQ问题,这里用的是ST算法
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 50005
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
using namespace std;
int a[maxn];
int maxsum[maxn][25];
int minsum[maxn][25];
void ST(int num) //预处理->O(nlogn)
{
for(int i=1;i<=num;++i){
maxsum[i][0] = a[i];
minsum[i][0] = a[i];
}
for(int j=1; j<20; ++j){
for(int i=1; i+(1<<j)<=num+1; ++i){
maxsum[i][j] = max(maxsum[i][j-1], maxsum[i+(1<<(j-1))][j-1]); //区间最大
minsum[i][j] = min(minsum[i][j-1], minsum[i+(1<<(j-1))][j-1]); //区间最小
}
}
}
int query_max(int l, int r) //查询->O(1)
{
int k = 0;
if(l>r) return 0;
while((1 << (k +1)) <= r - l + 1)k++;
return max(maxsum[l][k], maxsum[r - (1 << k) + 1][k]);
}
int query_min(int l,int r)
{
int k = 0;
if(l>r) return 0;
while((1 << (k +1)) <= r - l + 1)k++;
return min(minsum[l][k], minsum[r - (1 << k) + 1][k]);
}
int main()
{
int n,m,x,y;
while(scanf("%d %d",&n,&m)!=EOF){
for(int i=1;i<=n;++i){
scanf("%d",&a[i]);
}
ST(n);
for(int i=1;i<=m;++i){
scanf("%d %d",&x,&y);
int ans = query_max(x,y)-query_min(x,y);
printf("%d\n",ans);
}
}
return 0;
}