Multiply game HDU - 3074

                                                Multiply game     HDU - 3074 

Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence. 
  To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he… 
 

Input

The first line is the number of case T (T<=10). 
  For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an, 
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms: 
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n) 
1 k p; the kth number of the sequence has been change to p. (1<=k<=n) 
You can assume that all the numbers before and after the replacement are no larger than 1 million. 

Output

For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.

Sample Input

1
6
1 2 4 5 6 3
3
0 2 5
1 3 7
0 2 5

Sample Output

240
420

题意:T个测试案例,6个数,3次操作,三个数(op,x,y),op代表操作,如果为0:询问从第x个到第y个的乘积,若为1:将第x个数更新为y

思路:裸线段树,有个坑点就是需要把数组开的大些,按照题目里的大小是不够的,我的代码中开了1e6

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 100005
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
#define MID(l,r) (l+(r-l)/2)
#define lson(o) (o<<1) //o*2
#define rson(o) (o<<1|1) //o*2+1
using namespace std;

LL a[maxn];
int p,v;
int ql,qr;
struct node
{
    LL l,r,mul;
}tree[maxn*4];
void build(int o,int l,int r)
{
    tree[o].l = l;
    tree[o].r = r;
    if(l==r){
        tree[o].mul = a[l];
        return ;
    }
    int m = MID(l,r);
    int lc = lson(o),rc = rson(o);
    build(lc,l,m);
    build(rc,m+1,r);
    tree[o].mul = (tree[lc].mul * tree[rc].mul)%mod;
}
LL ans;
void query(int o)
{
    if(ql <= tree[o].l && qr >= tree[o].r){
        ans *= tree[o].mul;
        ans %= mod;
        return ;
    }
    int m =MID(tree[o].l,tree[o].r);
    int lc = lson(o),rc = rson(o);
    if(ql <= m) query(lc);
    if(qr > m) query(rc);
}
void update(int o)
{
    if(tree[o].l == tree[o].r){
        tree[o].mul = v;
        return ;
    }
    int m = MID(tree[o].l,tree[o].r);
    int lc = lson(o),rc = rson(o);
    if(p<=m) update(lc);
    else update(rc);
    tree[o].mul = (tree[lc].mul*tree[rc].mul)%mod;
}
int main()
{
    int T,n,m,op;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        for(int i=1;i<=n;++i) scanf("%lld",&a[i]);
        build(1,1,n);
        scanf("%d",&m);
        while(m--){
            scanf("%d",&op);
            if(op==0){
                scanf("%d %d",&ql,&qr);
                ans = 1;
                query(1);
                printf("%lld\n",ans);
            }
            else{
                scanf("%d %d",&p,&v);
                update(1);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值