poj 1422&&hdoj 1151 Air Raid

Air Raid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4163    Accepted Submission(s): 2767


Problem Description
Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
 

Input
Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.
 

Output
The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.
 

Sample Input
  
  
2 4 3 3 4 1 3 2 3 3 3 1 3 1 2 2 3
 

Sample Output
  
  
2 1
题意:有一个城镇,它的所有街道都是单行的,并且每条街道都是和两个路口相连。同时已知街道不会形成回路。现在要一些伞兵去巡查这个城镇,伞兵只能沿着路的方向走,你的任务是编写程序求最小数量的伞兵,使这些伞兵可以访问所有的路口。对于伞兵的起始降落点不做限制。

    其实就是给一个m个点n条边的有向无环图,求该图的最小路径覆盖。

    最小路径覆盖数=顶点数-最大匹配数。

代码:

#include<stdio.h>
#include<string.h>
#define N 1010
int map[N][N],mode[N],vis[N];
int n,m,k;
int find(int x)//寻找增广路! 找到返回1,否则返回0! 
{
	int i,j;
	for(i=1;i<=n;i++)
	{
		if(map[x][i]&&!vis[i])//与x相连点,并且没有遍历到 
		{
			vis[i]=1;//标记为遍历过
			if(mode[i]==0||find(mode[i]))//i 点 没有和另一部分匹配或 和i配对的点 没有匹配! 
			{
				mode[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(map,0,sizeof(map));
		memset(mode,0,sizeof(mode));
		while(m--)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			if(x&&y)
			map[x][y]=1;//标记为通路 
		}
		int s=0;
		for(i=1;i<=n;i++)
		 {
		 	memset(vis,0,sizeof(vis));
		 	if(find(i))//增广路 
		 	{
		 	s++;
		    }
		 }
		 printf("%d\n",n-s);
	}
	return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值