LA 4329 Ping pong乒乓比赛【树状数组】

LA 4329 Ping pong乒乓比赛【树状数组】http://www.bnuoj.com/bnuoj/problem_show.php?pid=11211

[PDF Link]

N (3$ \le$N$ \le$20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T (1$ \le$T$ \le$20) , indicating the number of test cases, followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N , the number of players. Then N distinct integers a1a2...aN follow, indicating the skill rank of each player, in the order of west to east ( 1$ \le$ai$ \le$100000 , i = 1...N ).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1
3 1 2 3

Sample Output

1

Source

【题意】一条街上n个乒乓球爱好者,每个人有不同的技能ai。每场比赛有两个选手和一名裁判,规定裁判必须住在两个选手中间,并且技能值也在两个选手之间。问一共能组织多少种比赛。

【思路】考虑第i个人,假设a1到ai-1中有ci个比ai小,那么就有(i-1)-ci个比ai大;同理,如果ai+1到an中有di个比ai小,那么就有(n-i)-di个比ai大。更具乘法原理和加法原理,i当裁判就有

             ci * (n-i-di) + (i-1-ci)*di   种比赛。(感觉这种思路简直碉堡了)然后问题就转化为了计算数组c和数组d。这样的话就很容易想到使用树状数组去计算前缀和。
	【代码如下】
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn = 100000+10;
long long c[maxn], d[maxn], xx[maxn];
int a[20005];

int lowbit(int x)
{
    return x & (-x);
}

void add(int x, int y)
{
    while(x <= maxn){
        xx[x] += y;
        x += lowbit(x);
    }
}

long long sum(int x)
{
    long long ret = 0;
    while(x > 0){
        ret += xx[x];
        x -= lowbit(x);
    }
    return ret;
}

int main()
{
    int cas;
    scanf("%d", &cas);
    while(cas--)
    {
        memset(c, 0, sizeof(c));
        memset(d, 0, sizeof(d));
        memset(xx, 0, sizeof(xx));
        int n;
        scanf("%d", &n);
        for(int i=1; i<=n; i++)
            scanf("%d", &a[i]);
        for(int i=1; i<=n; i++){
            add(a[i], 1);
            c[i] = sum(a[i]-1);
        }
        memset(xx, 0, sizeof(xx));
        for(int i=n; i>=1; i--){
            add(a[i], 1);
            d[i] = sum(a[i]-1);
        }
        long long ans = 0;
        for(int i=2; i<n; i++)
            ans += c[i]*(n-i-d[i]) + d[i]*(i-c[i]-1);

        printf("%lld\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值