Uva 11235 Frequent values 【RMQ问题】

Uva 11235 Frequent values 【RMQ问题】http://www.bnuoj.com/bnuoj/problem_show.php?pid=19653

2007/2008 ACM International Collegiate Programming Contest 
University of Ulm Local Contest

Problem F: Frequent values

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input Specification

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an(-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the query.

The last test case is followed by a line containing a single 0.

Output Specification

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input
10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0
Sample Output
1
4
3
【题意】给出一个非递减序列的整数数组a1,...,an,对于一系列的询问(i,j),回答 ai ~ aj 中出现次数最多的值所出现的次数。

【分析】把该序列进行游程编码(Run Length Encoding, RLE),比如,-1,1,1,2,2,2,4可编码成(-1,1),(1,2),(2,3),(4,1),其中(a,b)表示有b个连续的a。用value[i]和cnt[i]分别表示第i段的数值和出现的次数,num[p],Left[p],Right[p]表示位置p所在段的编号和左右端点位置。每次查询(L,R)的结果是以下三部分的最大值:Right[L]-L+1,R-Left[R]+1,RMQ(num[L]+1, num[R]-1)中的cnt最大值;如果L和R在同一数据段中,则为R-L+1。

【代码如下】

//Accepted	GNU C++	232ms	2255B
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <climits>

using namespace std;

const int maxn = 100000+10;
int cnt[maxn], num[maxn], Left[maxn], Right[maxn];
//cnt[]表示第i个数据段的元素个数, num[]表示位置p所在段的编号
//left[]、right[]表示位置p所在段的左右端点位置
int d[maxn][20];
int n, q, ssize;//ssize表示cnt[]的数据段元素个数

void RLE()//读数据,进行游程编码
{
    int x, pre = INT_MAX;//pre记录当前相同的数据元素
    int cur = 0;//当前数据段的位置指针
    int l;//l 是当前数据段的最左的边界
    for(int i=1; i<=n; i++)
    {
        scanf("%d", &x);
        if(x == pre){
            cnt[cur]++; num[i] = cur;
            Left[i] = l;
        }
        else{
            if(cur > 0){ //设置右端点
                for(int j=l; j<=i-1; j++)
                    Right[j] = i-1;
            }
            cur++;
            l = i;
            num[i] = cur;
            Left[i] = l;
            cnt[cur] = 1;
            pre = x;
        }
    }
    for(int i=l; i<=n; i++)
        Right[i] = n;//设置最后一个数据段的右端点位置
    ssize = cur;//共有多少个数据段
}
//元素从1编号到n
void RMQ_init()
{
    for(int i=1; i<=ssize; i++) d[i][0] = cnt[i];
    for(int j=1; (1<<j) <= ssize; j++)
        for(int i=1; i+j-1 <= ssize; i++)
            d[i][j] = max(d[i][j-1], d[i + (1<<(j-1))][j-1]);
}

int RMQ(int L, int R)
{
    if(L>R) return 0;
    int k=0;
    while((1<<(k+1)) <= R-L+1) k++;
    return max(d[L][k], d[R-(1<<k)+1][k]);
}

int main()
{
    while(cin>>n && n!=0)
    {
        scanf("%d", &q);

        RLE();
        RMQ_init();

        while(q--)
        {
            int L, R;
            scanf("%d %d", &L, &R);
            if(num[L] == num[R]) //在相同数据段
                printf("%d\n", R-L+1);
            else
            {
                int t1 = Right[L]-L+1;
                int t2 = R-Left[R]+1;
                int t3 = RMQ(num[L]+1, num[R]-1);
                printf("%d\n", max(t1, max(t2, t3)));
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值