前面的两个就不写了。以后我没做完一个例题就会发表一篇。不过时间不定,我有时也很少有时间来练习这些题。
/*
acm_1002
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
*/
#include<iostream>
#include<cstring>
using namespace std;
char *add(char *a,char *b) //定义函数
{
int i,j,k=0; //循环变量的定义
int temp[1001];
int length1 = strlen(a);
int length2 = strlen(b);
for(i = length1-1, j = length2 -1 ; i >= 0&&j >= 0; --i,--j)
temp[k++] = a[i] + b[j] - '0' - '0';
for(;i >= 0; --i)
temp[k++] = a[i] - '0';
for(;j >= 0; --j)
temp[k++] = b[j] - '0';
temp[k] = 0;
for(i = 0;i < k; ++i)
{
temp[i+1] += temp[i] / 10;
temp[i] %=10;
}
if(!temp[k]) k--;
for(i = 0;i <= k;i++)
a[i] = temp[k-i] + '0';
a[k+1] = '/0';
return a;
}
int main()
{
char a[1001],b[1001],*r;
int number = 0;
int k = 1;
cin >> number;
while(number--)
{
if(cin >> a >> b)
{
cout << "Case "<< k++ << ":/n" << a << " + " << b <<" = ";
r = add(a,b);
cout << r;
cout << endl;
if(number)
cout<<endl;
}
}
return 0;
}