C 单词统计 SDUT

Time Limit: 1000 ms Memory Limit: 65536 KiB


Problem Description

从键盘输入一行字符(长度小于100),统计其中单词的个数,各单词以空格分隔,且空格数可以是多个。


Input

输入只有一行句子。仅有空格和英文字母构成。


Output

单词的个数。


Sample Input

stable marriage problem Consists of Matching members


Sample Output

7

Hint

Source


本题 思路 :
在这里插入图片描述

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
   int main()
   {
       char a[101];
       int worde=0,count=0,i;
       gets(a);
       for(i=0;a[i]!='\0';i++)
       {
         if(a[i]==' ') worde = 0;
         else if(worde==0)
         {
             count++;
             worde=1;
         }
       }
     printf("%d\n",count);
       return 0;
   }

运行结果:
stable marriage  problem Consists     of Matching members
7

Process returned 0 (0x0)   execution time : 3.746 s
Press any key to continue.


  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

碧羽o(* ̄▽ ̄*)ブ回雪

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值