C逆序建立链表 SDUT

Time Limit: 1000 ms Memory Limit: 65536 KiB


Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。


Input

第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。


Output

依次输出单链表所存放的数据。


Sample Input

10
11 3 5 27 9 12 43 16 84 22


Sample Output

22 84 16 43 12 9 27 5 3 11


Hint

不能使用数组!


Source


方法一:先建立一个头节点,以后的节点连在头结点后面,下面有图形演示;

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int a;
    struct node *next;
};
//自定义两个函数;
struct node *creat(int n);//链表建立函数;
void display(struct node *head);//链表输出函数;
int main()
{

    int n;
    struct node *head;
    scanf("%d",&n);
    head = creat(n);
    display(head);
    return 0;
}
struct node *creat(int n)
//头插法建立链表;
{
    struct node *head,*p;
    head = (struct node *)malloc(sizeof(struct node));
    head -> next = NULL;
    while(n--)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->a);
        p -> next = head -> next;
        head -> next = p;
        //每次插入头结点后面;
    }

    return(head);
};
void display(struct node *head)
{
    struct node *p = head -> next;
    while(p)
    {
        printf("%d%c",p->a,p->next?' ':'\n');
        p = p -> next;
    }
}

代码二:

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;

};

int main()
{
    struct node *head,*p,*q;
    head = (struct node *)malloc(sizeof(struct node));
    head ->next = NULL;
    int n;
    scanf("%d",&n);
    while(n--)//链表建立;
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next = head -> next;//以上三句为定义一个新的节点的过程;
        head -> next = p;
    }
    q = head -> next;
 while(q)
    {
        if(q->next!= NULL)
            printf("%d ",q->data);
        else printf("%d\n",q->data);
        q = q->next;
    }
    return 0;

}

方法三:顺序建立,逆序输出;

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;

};

int main()
{
    struct node *head,*p,*q;
    head = (struct node *)malloc(sizeof(struct node));
    head ->next = NULL;
    q = head;//定义一个指针只想第一个节点;
    int n;
    scanf("%d",&n);
    while(n--)//链表建立;
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&q->data);
        p->next = q;//以上三句为定义一个新的节点的过程;
        if(n!=0)
        q = p;
    }
  while (q!=NULL) //链表输出;
    {
        if(q->next!= NULL)
            printf("%d ",q->data);
        else printf("%d\n",q->data);
        q = q->next;
    }
    return 0;

}

think:方法一: 逆序建立链表的过程还是先建立头接头点,让后建立一个节点输入一个数,并将新建的链表连在头结点后面

1.在这里插入图片描述

再将其连接起来

2.在这里插入图片描述

在建立的节点始终连在头节点和第二个节点之间,以后就可以用循环实现

3.在这里插入图片描述

4.在这里插入图片描述

5.在这里插入图片描述

这样就和图2,相类似,即一次循环

  • 4
    点赞
  • 12
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

碧羽o(* ̄▽ ̄*)ブ回雪

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值