C 数据结构实验之链表三:链表的逆置 SDUT

Time Limit: 1000 ms Memory Limit: 65536 KiB


Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。


Input

输入多个整数,以-1作为结束标志。


Output

输出逆置后的单链表数据。


Sample Input

12 56 4 6 55 15 33 62 -1


Sample Output

62 33 15 55 6 4 56 12


Hint

不得使用数组。


Source


方法一:

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int a;
    struct node *next;
};
void display(struct node *head);//链表输出函数;
void f(struct node *head);//链表逆置函数;
int main()
{
    int a;
    struct node *head,*p,*q;
    head = (struct node*)malloc(sizeof(struct node));
    head -> next = NULL;
    q = head;
    while(~scanf("%d",&a)&&a!=-1)
    //建立链表;
    {
        p = (struct node*)malloc(sizeof(struct node));
        p -> next = NULL;
        p -> a = a;
        q ->  next = p;
        q = p;
    }
    f(head);//链表逆置;
    display(head);//链表输出;
    return 0;
}
void f(struct node *head)
{
    struct node *p = head -> next,*q;
    q = p -> next;
    p ->next = NULL;
    p = q -> next;
    while(q)
    {
        q -> next = head -> next;
        head -> next = q;
        q = p;
        if(p)
        p = p -> next;
    }

}
void display(struct node *head)
{
    struct node *p = head -> next;
    while(p)
    {
        printf("%d%c",p->a,p->next?' ':'\n');
        p = p -> next;
    }
}

链表逆序可以直接定义一个逆序链表;

#include <stdio.h>
#include <stdlib.h>
  struct node
  {
      int a;
      struct node *next;
  };
 void  show(struct node *head)
   {
       struct node *p;
       p = head -> next;
       while(p)
       {
           if(p->next==NULL)
           printf("%d",p->a);
           else printf("%d ",p->a);
           p = p-> next;

       }
   }
     int main()
     {
         int a1;
         struct node *head,*p;
         head = (struct node*)malloc(sizeof(struct node));
         head -> next = NULL;
         while(scanf("%d",&a1))
         {
             if(a1==-1) break;
             p = (struct node*)malloc(sizeof(struct node));
             p -> next = head -> next;
             head -> next = p;
             p -> a = a1;

         }
         show(head);
         return 0;
     }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

碧羽o(* ̄▽ ̄*)ブ回雪

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值