C Number Steps SDUT


Problem Description

Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,… as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.
在这里插入图片描述

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0…5000.


Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.


Output

For each point in the input, write the number written at that point or write No Number if there is none.


Sample Input

3
4 2
6 6
3 4


Sample Output

6
12
No Number

Hint


Source
Tehran 2000


本题如果使用二维数组储存坐标轴的每一个点再进行计算,需要的空间会很大,而本题中要求的空间大小却比其他题目所允许的空间小,所以这样可能会超内存,所以可以观察坐标和结果的关系

#include <stdio.h>
#include <string.h>

int main()
{

   int n,x,y;
   scanf("%d",&n);

   while (n--)
   {
       scanf("%d%d",&x,&y);
       if (x == y)
        //当横纵坐标相等时;
       {
           if (x % 2 == 0)
           //如果坐标是偶数;
           {
               printf("%d\n",2 * x);
           }
           else
           //如果坐标是奇数;
           {
               printf("%d\n", (2 * x) - 1);
           }
       }
       else if (y == (x - 2))
       //如果纵坐标比横坐标小2;
       {
           if (x % 2 == 0)
           {
               printf("%d\n", ( 2 * x) - 2);
           }
           else
           {
               printf("%d\n",(2 * x) - 3);
           }
       }
       else
       //其他情况;
       {
           printf("No Number\n");
       }
   }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

碧羽o(* ̄▽ ̄*)ブ回雪

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值