数据结构实验之链表九:双向链表
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
学会了单向链表,我们又多了一种解决问题的能力,单链表利用一个指针就能在内存中找到下一个位置,这是一个不会轻易断裂的链。但单链表有一个弱点——不能回指。比如在链表中有两个节点A,B,他们的关系是B是A的后继,A指向了B,便能轻易经A找到B,但从B却不能找到A。一个简单的想法便能轻易解决这个问题——建立双向链表。在双向链表中,A有一个指针指向了节点B,同时,B又有一个指向A的指针。这样不仅能从链表头节点的位置遍历整个链表所有节点,也能从链表尾节点开始遍历所有节点。对于给定的一列数据,按照给定的顺序建立双向链表,按照关键字找到相应节点,输出此节点的前驱节点关键字及后继节点关键字。
输入
第一行两个正整数n(代表节点个数),m(代表要找的关键字的个数)。第二行是n个数(n个数没有重复),利用这n个数建立双向链表。接下来有m个关键字,每个占一行。
输出
对给定的每个关键字,输出此关键字前驱节点关键字和后继节点关键字。如果给定的关键字没有前驱或者后继,则不输出。
注意:每个给定关键字的输出占一行。
一行输出的数据之间有一个空格,行首、行末无空格。
示例输入
10 31 2 3 4 5 6 7 8 9 0350
示例输出
2 44 69
提示
来源
示例程序
#include <iostream>
#include <stdlib.h>
using namespace std;
struct node
{
int data;
struct node * prior;
struct node * next;
};
struct node * creat(int n)
{
struct node * head, * p, * tail;
head = (struct node * )malloc(sizeof(struct node));
head->prior = NULL;
head->next = NULL;
tail = head;
for(int i = 0; i < n; i++)
{
p =(struct node * )malloc(sizeof(struct node));
cin >> p->data;
p->next = NULL;
p->prior = NULL;
tail->next = p;
p->prior = tail;
tail = p;
}
return head;
};
void find(struct node * head, int x)
{
struct node * p;
p = head->next;
p->prior = NULL;
while(p != NULL)
{
if(p->data == x && p->next != NULL && p->prior != NULL)
cout << p->prior->data << " " << p->next->data << endl;
if(p->data == x && p->next != NULL && p->prior == NULL)
cout << p->next->data << endl;
if(p->data == x && p->next == NULL && p->prior != NULL)
cout << p->prior->data << endl;
p = p->next;
}
}
int main()
{
int n, m, x;
struct node * head;
cin >> n >> m;
head = creat(n);
while(m--)
{
cin >> x;
find(head, x);
}
return 0;
}