给定每个人的家庭成员和其自己名下的房产,请你统计出每个家庭的人口数、人均房产面积及房产套数。
输入格式:
输入第一行给出一个正整数N(<=1000),随后N行,每行按下列格式给出一个人的房产:
编号 父 母 k 孩子1 … 孩子k 房产套数 总面积
其中 编号 是每个人独有的一个4位数的编号;父 和 母 分别是该编号对应的这个人的父母的编号(如果已经过世,则显示-1);k(0<=k<=5)是该人的子女的个数;孩子i是其子女的编号。
输出格式:
首先在第一行输出家庭个数(所有有亲属关系的人都属于同一个家庭)。随后按下列格式输出每个家庭的信息:
家庭成员的最小编号 家庭人口数 人均房产套数 人均房产面积
其中人均值要求保留小数点后3位。家庭信息首先按人均面积降序输出,若有并列,则按成员编号的升序输出。
输入样例:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
输出样例:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
这里就不给代码加注释了,实在代码写的太丑,先看题解的去搜其他人博客吧,我只是想记录我第一180行的代码,以后看到自己代码会不会想删呢~~
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAX_NUM 10000
using namespace std;
int pre[MAX_NUM+10];
bool book[MAX_NUM+10];
int top = 0;
struct node{
int min;
int number;
int father;
int mother;
int sum_people;
int k;
int child[10];
int house_num;
double house_sum_area;
}s[1005];
struct date{
int min;
int num;
double house_sum_num;
double house_sum_area;
}ans[1005];
bool cmp(struct date a,struct date b)
{
if(a.house_sum_area/a.num > b.house_sum_area/b.num)
return 1;
if(a.house_sum_area/a.num == b.house_sum_area/b.num)
{
if(a.min < b.min)
return 1;
}
return 0;
}
int find(int x)
{
int r = x;
while(pre[r] != r)
r = pre[r];
int i = x,j;
while(i != r)
{
j = pre[i];
pre[i] = r;
i = j;
}
return r;
}
void add(int x,int y)
{
int fx = find(x);
int fy = find(y);
if(fx != fy)
pre[fx] = fy;
}
void need(struct node *a)
{
a->sum_people = 1;
a->min = a->number;
if(a->father != -1)
{
add(a->father,a->number);
a->sum_people++;
if(a->father < a->min)
a->min = a->father;
}
if(a->mother != -1)
{
add(a->mother,a->number);
a->sum_people++;
if(a->mother < a->min)
a->min = a->mother;
}
a->sum_people += a->k;
for(int i=1;i<=a->k;i++)
{
add(a->child[i],a->number);
if(a->child[i] < a->min)
a->min = a->child[i];
}
}
void input(int n)
{
int i,j;
for(i=1;i<=n;i++)
{
scanf("%d %d %d %d",&s[i].number,&s[i].father,&s[i].mother,&s[i].k);
for(j=1;j<=s[i].k;j++)
{
scanf("%d",&s[i].child[j]);
}
scanf("%d %lf",&s[i].house_num,&s[i].house_sum_area);
need(&s[i]);
}
}
void startup(struct node *a,int i)
{
ans[i].min = a->min;
ans[i].num = a->sum_people;
ans[i].house_sum_num = a->house_num;
ans[i].house_sum_area = a->house_sum_area;
}
void sign(struct node *a)
{
book[a->number] = 1;
book[a->father] = 1;
book[a->mother] = 1;
for(int i=1;i<=a->k;i++)
{
book[a->child[i]] = 1;
}
}
void startadd(struct node *a,int i)
{
int j;
if(book[a->number] == 0)
{
ans[i].num++;
book[a->number] = 1;
if(a->number < ans[i].min)
ans[i].min = a->number;
}
if(book[a->father] == 0 && a->father != -1)
{
ans[i].num++;
book[a->father] = 1;
if(a->father < ans[i].min)
ans[i].min = a->father;
}
if(book[a->mother] == 0 && a->mother != -1)
{
ans[i].num++;
book[a->mother] = 1;
if(a->mother < ans[i].min)
ans[i].min = a->mother;
}
for(j=1;j<=a->k;j++)
{
if(book[a->child[j]] == 0)
{
ans[i].num++;
book[a->child[j]] = 1;
if(a->child[j] < ans[i].min)
ans[i].min = a->child[j];
}
}
ans[i].house_sum_num += a->house_num;
ans[i].house_sum_area += a->house_sum_area;
}
int main(void)
{
int i,j,n;
for(i=1;i<=MAX_NUM;i++)
pre[i] = i;
memset(book,0,sizeof(book));
scanf("%d",&n);
input(n);
top++;
startup(&s[1],top);
sign(&s[1]);
for(i=2;i<=n;i++)
{
for(j=1;j<=top;j++)
{
if(find(s[i].min) == find(ans[j].min))
{
startadd(&s[i],j);
break;
}
}
if(j > top)
{
top++;
startup(&s[i],top);
sign(&s[i]);
}
}
sort(ans+1,ans+1+top,cmp);
printf("%d\n",top);
for(i=1;i<=top;i++)
printf("%04d %d %.3lf %.3lf\n",ans[i].min,ans[i].num,ans[i].house_sum_num/ans[i].num,ans[i].house_sum_area/ans[i].num);
return 0;
}
这代码写的真是曲折的很啊,两天想想改改的,主要还是思路不太好吧,乱七八糟写了六七个函数。囧。