poj-3255-Roadblocks (求到源点的次短路,Dijkstra改进)

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers: N and R
Lines 2.. R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450
Hint
Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

题意就是给你N个点,R条边,然后求出1到N的次短路的路程,这里一条边可以用两次,而且也可以和最短路的路径重复

思路,比如到V这个点的次短路,一定就是到与他连接的一个u的点的最短路,再加上u到v这条边,或者是到u的次短路,再加上v这条边,注意这里u是指到V的一源点,不是具体的某个点,故这里我是参考了《挑战程序设计第二版》这本书,对Dijkstra进行改进,由于是稠密图,故用邻接表存图,并且用堆来进行优化。

完整代码如下:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<vector>
#include<queue>
#include<algorithm>
#define MAX_V 5010
#define MAx_E 100010
using namespace std;
int V,E;
const int INF = 99999999;
int first_short[MAX_V],second_short[MAX_V];//代表最短距离和次短距离 
typedef pair<int,int> P;//first代表到该点距离,second代表该点编号,这里也可用结构体代替 
struct Edge{int to,cost;}; 
vector<Edge>G[MAX_V];
void Dijkstra(int a){
    priority_queue<P,vector<P>,greater<P> >q;
    fill(first_short+1,first_short+1+V,INF);
    fill(second_short+1,second_short+1+V,INF);
    first_short[1] = 0;
    q.push(P(0,1));
    while(!q.empty()){
        P p = q.top();q.pop();
        int v = p.second;
        int d = p.first;
        if(second_short[v] < d) continue;//这一句话也可以去掉,因为放入堆中的最长也是次短路的距离 
        for(int i=0;i<G[v].size();i++){
            Edge e = G[v][i];
            int d2 = d + e.cost;//d2代表走这条边的情况 

            if(first_short[e.to] > d2){//如果走这条边后到e.to这个点的距离比最短路还小,就交换他们 
                swap(first_short[e.to],d2);
                q.push(P(first_short[e.to],e.to));
            }
            if(second_short[e.to] > d2 && d2 > first_short[e.to]){//如果d2比最短小,比次短路长,就更新次短路的值 
                second_short[e.to] = d2;
                q.push(P(second_short[e.to],e.to));//这里次短路也要放入堆中,思考思路中的前几句话。 
            }
        }
    }
}
int main(void)
{
    while(~scanf("%d %d",&V,&E)){
        Edge e;
        int a,b,c;
        for(int i=1;i<=V;i++)
            G[i].clear();
        for(int i=1;i<=E;i++){//由于是无向图,故这里要存两次 
            scanf("%d %d %d",&a,&b,&c);
            e.to = b,e.cost = c;
            G[a].push_back(e);
            e.to = a,e.cost = c;
            G[b].push_back(e);
        }
        Dijkstra(1);
        printf("%d\n",second_short[V]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值