poj 1751 Highways (prim和kruskal)

链接
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can’t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input
9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output
1 6
3 7
4 9
5 7
8 3
题意很简单,就是求一个最下生成树,但是有一部分路已经修好了,然后求剩下需要连接那些边,最后输出这些边

用kruskal就是先用并查集吧已经连接的边连接,再用kruskal跑一下,并记录连接的边,不过比较慢,440ms
代码如下:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;

const int MAX_V = 800;
const int MAX_E = 1010;
int pre[MAX_V];
struct Edge{
    int x,y,z;
}q[MAX_V*400],res[MAX_E];

int Find(int x){
    int r = x;
    while(pre[r] != r)
        r = pre[r];
    int i = x,j;
    while(i != r){
        j = pre[i];
        pre[i] = r;
        i = j;
    }
    return r;
}

bool add(int x,int y){
    int fx = Find(x),fy = Find(y);
    if(fx != fy){
        pre[fx] = fy;
        return true;
    }
    return false;
}
bool cmp(Edge a,Edge b){
    return a.z < b.z;
}
int V,E,x[MAX_V],y[MAX_V];
bool e[MAX_V][MAX_V];
int main(void){
    while(scanf("%d",&V) != EOF){
        for(int i=1;i<=V;i++){
            scanf("%d %d",&x[i],&y[i]);
            pre[i] = i;
        }
        scanf("%d",&E);
        memset(e,false,sizeof(e));
        int top = 0;
        int a,b,Count = 0;
        for(int i=1;i<=E;i++){
            scanf("%d %d",&a,&b);
            e[a][b] = e[b][a] = true;
            if(add(a,b))//要判断这个边是否已经被连接。
                Count++;
        }
        for(int i=1;i<=V;i++){
            for(int j=i+1;j<=V;j++){
                if(e[i][j]) continue;//已经连接的边,不再计算,否则会超时
                int dis = pow(x[i] - x[j],2) + pow(y[i] - y[j],2);
                top++;
                q[top].x = i;q[top].y = j;q[top].z = dis;
            }
        }
        sort(q+1,q+1+top,cmp);
        int tt = 0;
        for(int i=1;i<=top;i++){
            if(add(q[i].x,q[i].y)){
                res[++tt] = q[i];
                Count++;
            }
            if(Count == V-1)    break;
        }
        for(int i=1;i<=tt;i++){
            printf("%d %d\n",res[i].x,res[i].y);
        }
    }
    return 0;
}

prim算法:就是把已经连接的边的距离就设置为0,然后用pre数组记录一下前趋点,不过在输出的边的时候要注意,如果两个点的距离为0,就不输出这个边,因为这个边已经被连接过了,相对比较快 110ms

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<set>
#include<queue>

using namespace std;
const int MAX_V = 800;
const int MAX_E = 1010;
const int INF = 0x3f3f3f3f;
int cost[MAX_V],e[MAX_V][MAX_V];
int V,E,x[MAX_V],y[MAX_V];
bool used[MAX_V];
int pre[MAX_V];
void prim(){
    fill(cost+1,cost+1+V,INF);
    memset(used,false,sizeof(used));
    memset(pre,0,sizeof(pre));
    cost[1] = 0;
    while(true){
        int u = -1;
        for(int i=1;i<=V;i++){
            if(!used[i] && (u == -1 || cost[i] < cost[u]))
                u = i;
        }
        if(u == -1) break;
        used[u] = true;
        for(int i=1;i<=V;i++){
            if(!used[i] && cost[i] > e[u][i]){
                cost[i] = e[u][i];
                pre[i] = u;
            }
        }
        if(e[u][pre[u]])    printf("%d %d\n",u,pre[u]);
    }

}
int main(void){
    while(scanf("%d",&V) != EOF){
        for(int i=1;i<=V;i++){
            scanf("%d %d",&x[i],&y[i]);
        }
        for(int i=1;i<=V;i++)
            for(int j=1;j<=V;j++){
                int dis = pow(x[i]-x[j],2) + pow(y[i]-y[j],2);
                e[i][j] = e[j][i] = dis;
            }

        scanf("%d",&E);
        int a,b;
        for(int i=1;i<=E;i++){
            scanf("%d %d",&a,&b);
            e[a][b] = e[b][a] = 0;
        }
        prim();
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值