POJ 2449 Remmarguts' Date (求第K短路,A* + Dijkstra)

“Good man never makes girls wait or breaks an appointment!” said the mandarin duck father. Softly touching his little ducks’ head, he told them a story.

“Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One day their neighboring country sent them Princess Uyuw on a diplomatic mission.”

“Erenow, the princess sent Remmarguts a letter, informing him that she would come to the hall and hold commercial talks with UDF if and only if the prince go and meet her via the K-th shortest path. (in fact, Uyuw does not want to come at all)”

Being interested in the trade development and such a lovely girl, Prince Remmarguts really became enamored. He needs you - the prime minister’s help!

DETAILS: UDF’s capital consists of N stations. The hall is numbered S, while the station numbered T denotes prince’ current place. M muddy directed sideways connect some of the stations. Remmarguts’ path to welcome the princess might include the same station twice or more than twice, even it is the station with number S or T. Different paths with same length will be considered disparate.
Input
The first line contains two integer numbers N and M (1 <= N <= 1000, 0 <= M <= 100000). Stations are numbered from 1 to N. Each of the following M lines contains three integer numbers A, B and T (1 <= A, B <= N, 1 <= T <= 100). It shows that there is a directed sideway from A-th station to B-th station with time T.

The last line consists of three integer numbers S, T and K (1 <= S, T <= N, 1 <= K <= 1000).
Output
A single line consisting of a single integer number: the length (time required) to welcome Princess Uyuw using the K-th shortest path. If K-th shortest path does not exist, you should output “-1” (without quotes) instead.
Sample Input
2 2
1 2 5
2 1 4
1 2 2
Sample Output
14

题意:非常裸的题目就是求s到t的第K短路。

思路:由于是有向图,要反向存边,然后跑一下Dijkstra获得每个点到t的最短路,然后再用A*用函数H(s) = 当前已走距离g + 到目标节点的最短距离dis[s];
求第k短路就是第k次访问到这个节点所走的路径,不过这个题目有一个大坑,就是当起点与终点相同时,第一短并不是0,而是下次访问时,所以如果s == t要执行k++的操作相当于求K+1短路。

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>

using namespace std;
const int MAX_V = 1010;
const int MAX_E = 100010;
const int INF = 0x3f3f3f3f;
int V,E,K;
struct Edge{
    int to,cost;
};
struct Node{
    int v,g,f;//这里的f就是每个节点的H(v);
};
vector<Edge> G[MAX_V],RG[MAX_V];//G是正向边,RG是反向存边
int dis[MAX_V];
struct Rule{
    bool operator()(const int A,const int B){
        return dis[A] > dis[B];
    }
};
struct cmp{//每次去H(s)最小的
    bool operator()(const Node A,const Node B){
        if(A.f > B.f)   return true;
        else if(A.f == B.f && A.g > B.g)    return true;
        else    return false;
    }
};
void add(int u,int v,int w){
    G[u].push_back((Edge){v,w});
    RG[v].push_back((Edge){u,w});
}
void Dijkstra(int s_){//求出每个节点到s_的最短路
    for(int i=1;i<=V;++i)   dis[i] = INF;
    dis[s_] = 0;
    priority_queue<int,vector<int>,Rule> q;
    q.push(s_);
    while(!q.empty()){
        int v = q.top();q.pop();
        for(vector<Edge>::iterator it = RG[v].begin();it != RG[v].end();++it){
            if(dis[it->to] > dis[v] + it->cost){
                dis[it->to] = dis[v] + it->cost;
                q.push(it->to);
            }
        }
    }
}

void init(){
    for(int i=1;i<=V;++i){
        G[i].clear();
        RG[i].clear();
    }
}

int Astar(int s,int t){//就是用堆优化的BFS
    priority_queue<Node,vector<Node>,cmp> q;
    q.push((Node){s,0,dis[s]});
    if(s == t)  K++;
    int cnt = 0;
    while(!q.empty()){
        Node e = q.top();q.pop();
        if(e.v == t){
            cnt++;
            if(cnt == K)    return e.g;
        }
        for(vector<Edge>::iterator it = G[e.v].begin();it != G[e.v].end();++it){
            Node es;
            es.v = it->to;
            es.g = e.g + it->cost;
            es.f = es.g + dis[es.v];
            q.push(es);
        }
    }
    return -1;
}
int main(void){
    while(scanf("%d %d",&V,&E) != EOF){
        init();
        int x,y,z;
        for(int i=1;i<=E;++i){
            scanf("%d %d %d",&x,&y,&z);
            add(x,y,z);
        }
        int s,t;
        scanf("%d %d %d",&s,&t,&K);
        Dijkstra(t);

        printf("%d\n",Astar(s,t));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值